Unraid OS version 6.10.3 available


Recommended Posts

The primary purpose of this release is to address an issue seen with many HP Microserver Gen8/9 servers (and other platforms) where data corruption could occur if Intel VT-d is enabled. 

 

ALL USERS are encouraged to update.

 

As always, please make a flash back up before upgrading: Main/Flash/Flash Backup.

 

While we have not identified the exact kernel commit that introduced this issue, we have identified a solution that involves changing the default IOMMU operational mode in the Linux kernel from "DMA Translation" to "Pass-through" (equivalent to "intel_iommu=pt" kernel option).  At first, we thought the 'tg3' network driver was the culprit; however, upon thorough investigation, we think this is coincidental and we have also removed code that "blacklists" the tg3 driver.

 

Special thanks to @JorgeB who helped characterize and report this issue, as well as helping many people recover data when possible.  Please refer to the Unraid OS 6.10.3-rc1 announcement post for more information.

 


Version 6.10.3 2022-06-14

Improvements

Fixed data corruption issue which could occur on some platforms, notably HP Microserver Gen8/9, when Intel VT-d was enabled. This was fixed by changing the Linux kernel default IOMMU operation mode from "DMA Translation" to "Pass-through".

  • Also removed 'tg3' blacklisting when Intel VT-d was enabled. This was added in an abundance of caution as all early reports of data corruption involved platforms which also (coincidentally) used 'tg3' network driver. If you created a blank 'config/modprobe.d/tg3.conf' file you may remove it.

 

Plugin authors: A plugin file may include a tag which displays a markdown formatted message when a new version is available. Use this to give instructions or warnings to users before the upgrade is done.

 

Brought back color-coding in logging windows.

Bug fixes

Fix issue detecting Mellanox NIC.

 

Misc. webGUI bug fixes

Change Log vs. Unraid OS 6.10.2

Base distro:

  • no changes

Linux kernel:

  • version 5.15.46-Unraid
  • CONFIG_IOMMU_DEFAULT_PASSTHROUGH: Passthrough

Management:

  • startup: improve network device detection
  • webgui: Added color coding in log files
  • webgui: In case of flash corruption try the test again
  • webgui: Improved syslog reading
  • webgui: Added log size setting when viewing syslog
  • webgui: Plugin manager: add ALERT message function
  • webgui: Add INFO icon to banner
  • webgui: Added translations to PageMap page
  • webgui: Fix: non-correcting parity check actually correcting if non-English language pack installed
  • webgui: Updated azure/gray themes
    • Better support for Firefox
    • Move utilization and notification indicators to the right
  • Like 14
  • Thanks 3
  • Upvote 1
Link to comment

Could you provide more information on the Mellanox NIC bug fix? 

I have 2 connectx-2 cards flashed to ethernet mode (with the unraid plugin). The cards were correctly detected and showing up in the plugin, but the link appeared down even though it was properly connected. Could this be related, or is my qsfp cable bad? Also there were a few strange issues with the network config of other NICs when the mellanox card was plugged in.

 

It wasn't a critical issue at the time, so I dropped the matter, but if it is fixed now, it would be great to have 10gbit. 

Link to comment
1 hour ago, mmmeee15 said:

Could this be related

Unlikely, AFAIK the only thing that changed is the device detection during boot, that looks more like driver/initialization issue, I would recommend starting a new thread in the general support forum and please don't forget the diagnostics.

Link to comment

This update bricked my system. I attached monitor and there's no anything on the screen after the BIOS screen.

Network card was blinking but I wasn't able to ping it.

 

Thankfully I made boot drive backup right before the update. So I flashed it again and now it works fine (on 6.10.2).

Unfortunately I made backup right during the parity check (scheduled on 15th of every month) and it started another parity check right after the boot and instantly found 1 error...

I hope it's some bug when parity starts after the boot, because it finished today without any errors, before I upgraded to 6.10.3.

Link to comment
27 minutes ago, JorgeB said:

Unlikely, AFAIK the only thing that changed is the device detection during boot, that looks more like driver/initialization issue, I would recommend starting a new thread in the general support forum and please don't forget the diagnostics.

Will do. I'm getting a new cable shortly, and will post if needed. 

 

Thank you

Link to comment
10 minutes ago, Kagami Hiiragi said:

I attached monitor and there's no anything on the screen after the BIOS screen.

Do you mean right after the BIOS, i.e., you don't even see the Unraid boot menu? If that's true can't see how it can be because of the update.

Link to comment

Updated my gen8 Microserver from 6.10.2 without incident. Decided to leave VT-d off in BIOS, as I don't use VMs anyhow.

Sonarr and Radarr Dockers both started fine and GUIs load (haven't tried searching, but I don't think there'll be problems).

Link to comment
48 minutes ago, joggs said:

Many of the sqlite images became broken after the upgrade, for example radarr and sonarr

I would guess unrelated to the update (if you updated from another v6.10.x release) but please start a new thread in the general support forum and don't forget to include the diagnostics after array start.

 

 

Link to comment

why does it keep installing the newest Nvidia driver after every update? I use a gt for Plex and it always rolls to the latest vs keeping me on the 470.129.06 which is the one that works for this card.

Link to comment
19 minutes ago, pkoci1 said:

It seems that Time machine backup has not been fixed and the host still cannot access containers on custom network via IPv6.

The TimeMachine docker is working great for me. You might want to check that out. Supports AFP too although I haven’t tried that.

Link to comment

Humm upgraded turned virtualization back on I can get to my VM through NoMachine, but if i try to vnc from the vm manger it never connects.  I read a post from 2018 or 2016 that talked about clearing cookies and fixing but that did not work here.

Link to comment
17 hours ago, 1812 said:

why does it keep installing the newest Nvidia driver after every update? I use a gt for Plex and it always rolls to the latest vs keeping me on the 470.129.06 which is the one that works for this card.

I believe that's because the update process checks that all plugins are up to date before asking you to reboot in the situation that there's an update that's needed for the plugin to be compatible with that version of Unraid. Not sure if this is something you can disable.

Link to comment

Everything works as expected however, both the main page and the dashboard show no hardware information whatsoever. I see no disks, no CPU stats, no Fan stats, no array however everything else is working just fine. Not sure where to start to troubleshoot this...

1.PNG

2.PNG

3.PNG

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.