[Support] binhex - DelugeVPN


8664 posts in this topic Last Reply

Recommended Posts

Hi there. Sorry if this has been answered a million times, I can't find anything helpful.I am unable to manually add a torrent file to Deluge.

I browse to the torrent file, but I can't click Add, nothing happens. The Deluge windows also doesn't list what files would be downloaded.

 

I'm having the same problem as this person:

https://github.com/binhex/arch-delugevpn/issues/152

I know nothing about iframes or whatever he's talking about. I've tried Chrome, Safari, Firefox.

 

Thanks for any ideas. Downloads from radarr and sonarr work perfectly.

Edited by stor44
submitted post before I was done writing it.
Link to post
  • Replies 8.7k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

There has been an issue raised on GitHub related to tracker announce request IP leakage under certain circumstances, after careful review of iptables i have tightened up the rules to prevent this. A n

OK guys, multi remote endpoint support is now in for this image please pull down the new image (this change will be rolled out to all my vpn images shortly).   What this means is that the im

I wanted to summarize how I got Mullvad working with DelugeVPN as I had to piece together several "solutions" from different comments in this thread and there was some incorrect info; likely old.

Posted Images

2 hours ago, wgstarks said:

You need to edit your .ovpn file.

https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

Scroll down to Q20.

 

If you only want to use one endpoint you could also just replace your ovpn file with the correct one for that endpoint.

In my docker folder DelugeVPN/openvpn i have many *ovpn file. In my case the armenia.ovpn have recent modified date and time.  I have only credential.conf with this *.ovpn. 

Thanks for your help.

Link to post
2 minutes ago, jfmasson said:

In my docker folder DelugeVPN/openvpn i have many *ovpn file. In my case the armenia.ovpn have recent modified date and time.  I have only credential.conf with this *.ovpn. 

Thanks for your help.

You should only place one ovpn file in this folder, the file that corresponds to the server you wish to use. If you want, you can place the other files in a subfolder (see screenshot) for possible future need.

 

FinderScreenSnapz001.jpg.400d6989d02a8f4bb2d26f993a138169.jpg

Link to post
8 hours ago, Boose77 said:

Has anyone ran into an issue where they can't check the box next to WebUI? I'm trying to get Deluge to show in Organizr and it needs WebUi active.

If you are using the docker container, it should automatically have WebUI enabled (you don't need to check the box). What happens when enter the IP and Port into Organizr?

Link to post
22 hours ago, stor44 said:

Hi there. Sorry if this has been answered a million times, I can't find anything helpful.I am unable to manually add a torrent file to Deluge.

I browse to the torrent file, but I can't click Add, nothing happens. The Deluge windows also doesn't list what files would be downloaded.

 

I'm having the same problem as this person:

https://github.com/binhex/arch-delugevpn/issues/152

I know nothing about iframes or whatever he's talking about. I've tried Chrome, Safari, Firefox.

 

Thanks for any ideas. Downloads from radarr and sonarr work perfectly.

I'm curious - do you have an adblocker turned on? I would start by turning that off. 

 

Alternatively, what if you setup a "watch" folder and just drop the torrent files in there? What is your setup and workflow like?

Link to post
On 2/5/2021 at 12:45 AM, Cark said:

Don't know if this should be here or in the wireguard thread, but I was wondering if anyone knew how to route an incoming connection from wireguard (like if I'm remoting in from my laptop) through privoxy in deluge. I can't seem to find anyone else who's wanting to do this lol.

 

When I was using openvpn to connect to my local network I could just turn on a proxy and boom I'm running through PIA, can't seem to figure out how to do that (or if it's possible) with wireguard.

It would be easier to just wireguard into your home network / unraid machine and access Deluge. Would this option work for you? You can setup remote tunneled access this way.

Link to post
3 hours ago, Rick_Sanchez said:

I'm curious - do you have an adblocker turned on? I would start by turning that off. 

 

Alternatively, what if you setup a "watch" folder and just drop the torrent files in there? What is your setup and workflow like?

Thanks for the reply. I've now tried Deluge in Chrome, Safari & Firefox and disabled any content blocking. Same issue persists.

 

I'm open to setting up a Watch folder, is that easy to do? (I'll google it). 95% of the time I only use binhex's Sonarr and Radarr Dockers to send torrents to Deluge. But once in a while I find something else I want to download so it would just be good to be able to add torrents manually. Thanks.

Link to post
3 hours ago, Rick_Sanchez said:

If you are using the docker container, it should automatically have WebUI enabled (you don't need to check the box). What happens when enter the IP and Port into Organizr?

I entered the IP with port and the password for deluge and this is the error im getting in Organizr V2

 

"could not log in due to curl error (. 56): Recv failure: connection reset by peer"

Link to post
3 hours ago, Boose77 said:

I entered the IP with port and the password for deluge and this is the error im getting in Organizr V2

 

"could not log in due to curl error (. 56): Recv failure: connection reset by peer"

Hey for posterity - did you also enter http://? i.e. http://deluge.ip.address:delugeport

Link to post
4 hours ago, stor44 said:

Thanks for the reply. I've now tried Deluge in Chrome, Safari & Firefox and disabled any content blocking. Same issue persists.

 

I'm open to setting up a Watch folder, is that easy to do? (I'll google it). 95% of the time I only use binhex's Sonarr and Radarr Dockers to send torrents to Deluge. But once in a while I find something else I want to download so it would just be good to be able to add torrents manually. Thanks.

Hey, a watch folder is not a bad idea (although I don't use one).

 

  • Simplest way may be to add a folder in your downloads directory. I.e. let's say you have /download/complete and download/incomplete
  • Create a /download/watch folder. 
  • Add watch folder functionality to Deluge, and add the 'download/watch' folder path to auto-add .torrent files
  • now move your .torrent files to this folder, and deluge should add it to download

 

Link to post
15 hours ago, Rick_Sanchez said:

Hey, a watch folder is not a bad idea (although I don't use one).

 

  • Simplest way may be to add a folder in your downloads directory. I.e. let's say you have /download/complete and download/incomplete
  • Create a /download/watch folder. 
  • Add watch folder functionality to Deluge, and add the 'download/watch' folder path to auto-add .torrent files
  • now move your .torrent files to this folder, and deluge should add it to download

 

Thanks for the help, that worked...However it only worked for the first torrent file I put in the watch folder. Deluge downloaded the torrent, then I added a second torrent file to the watch folder and it just sits there. Seems to be a common problem in this thread. I deleted the container and recreated it, but same thing, the watch folder processes first torrent then no others. Weird.

Link to post
21 hours ago, Rick_Sanchez said:

Hey for posterity - did you also enter http://? i.e. http://deluge.ip.address:delugeport

Yep! http://ipaddress:port/ and then the password for the deluge docker.

 

Organizr says to install a webapi plugin, but whenever i install it for Deluge, it doesn't do anything which is why im confused.

 

Thanks for the help!

Link to post
15 minutes ago, Boose77 said:

Yep! http://ipaddress:port/ and then the password for the deluge docker.

 

Organizr says to install a webapi plugin, but whenever i install it for Deluge, it doesn't do anything which is why im confused.

 

Thanks for the help!

Are you using a proxy by chance to access deluge? 

 

Did you download, install, and enable the WebAPI plugin / egg file?

 

Also you may not need the WebUI checkbox checked in order to get it into organizr. 

 

Alternatively, you can install Heimdall - it was pretty quick and easy to setup.

Link to post
5 hours ago, Rick_Sanchez said:

Are you using a proxy by chance to access deluge? 

 

Did you download, install, and enable the WebAPI plugin / egg file?

 

Also you may not need the WebUI checkbox checked in order to get it into organizr. 

 

Alternatively, you can install Heimdall - it was pretty quick and easy to setup.

Nope just standard docker access through unraid or organizr. I installed the webapi plugin that Organizr asked me too but it shows up as [objectlist] when i try installing it. Not a terribly big deal i just wanted to have deluge on the homepage.

Link to post
1 minute ago, Boose77 said:

Nope just standard docker access through unraid or organizr. I installed the webapi plugin that Organizr asked me too but it shows up as [objectlist] when i try installing it. Not a terribly big deal i just wanted to have deluge on the homepage.

If you haven’t already, try placing the egg file directly into the plugins folder and restart the docker. Sometimes works.

Link to post
On 2/8/2021 at 1:02 AM, justananon said:

2021-02-08 08:39:46,543 DEBG 'watchdog-script' stdout output:
[debug] Checking we can resolve name 'www.google.com' to address...

2021-02-08 08:39:46,623 DEBG 'watchdog-script' stdout output:
[debug] DNS operational, we can resolve name 'www.google.com' to address '172.217.1.164'

2021-02-08 08:39:46,623 DEBG 'watchdog-script' stdout output:
[debug] Waiting for iptables chain policies to be in place...

2021-02-08 08:39:46,634 DEBG 'watchdog-script' stdout output:
[debug] iptables chain policies are in place

2021-02-08 08:39:46,644 DEBG 'watchdog-script' stdout output:
[debug] VPN IP is 10.8.0.2
[debug] Deluge IP is 10.8.0.2

2021-02-08 08:39:47,085 DEBG 'watchdog-script' stderr output:

Traceback (most recent call last):
  File "/usr/lib/python3.8/site-packages/twisted/web/_newclient.py", line 1050, in dispatcher
    return func(*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/twisted/web/_newclient.py", line 1632, in _finishResponse_WAITING
    self._giveUp(Failure(reason))
  File "/usr/lib/python3.8/site-packages/twisted/web/_newclient.py", line 1685, in _giveUp
    self._disconnectParser(reason)
  File "/usr/lib/python3.8/site-packages/twisted/web/_newclient.py", line 1673, in _disconnectParser
    parser.connectionLost(reason)
--- <exception caught here> ---
  File "/usr/lib/python3.8/site-packages/twisted/web/_newclient.py", line 567, in connectionLost
    self.response._bodyDataFinished()
  File "/usr/lib/python3.8/site-packages/twisted/web/_newclient.py", line 1050, in dispatcher
    return func(*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/twisted/web/_newclient.py", line 1306, in _bodyDataFinished_CONNECTED
    self._bodyProtocol.connectionLost(reason)
  File "/usr/lib/python3.8/site-packages/deluge/httpdownloader.py", line 75, in connectionLost
    self.data = self.data.decode(self.encoding).encode('utf8')
builtins.UnicodeDecodeError: 'utf-8' codec can't decode byte 0xfb in position 319: invalid start byte

 

Trying to add via magnet links from certain trackers is giving me this error (which doesn't seem very helpful).  The same magnetlink works fine in the rtorrentvpn docker on the same machine.  The delugevpn docker also works on some other trackers.  Not sure what more information to get or how to get more thorough logs to see what's going wrong.

Edit:  Also, if I add via magnet link to rtorrent and then use that torrent file (or just directly download the torrent file to my computer) I can add the torrent fine through the torrent file.  So it seems like something with resolving the magnet link?


Anyone? Any ideas?

Link to post

Is anyone else using the AutoAdd plugin?

 

It used to work a treat for me but, sometime recently, it has stopped recognising new .torrent files.  I don't think I have changed any settings but, in any case, changing settings shouldn't stop it recognising new files entirely.

 

It cannot be an installation problem since AutoAdd is a 'standard' plugin - part of the Deluge distribution.

 

I would love to have it working again - any ideas/suggestions?

Link to post
4 hours ago, PeterB said:

Is anyone else using the AutoAdd plugin?

 

It used to work a treat for me but, sometime recently, it has stopped recognising new .torrent files.  I don't think I have changed any settings but, in any case, changing settings shouldn't stop it recognising new files entirely.

 

It cannot be an installation problem since AutoAdd is a 'standard' plugin - part of the Deluge distribution.

 

I would love to have it working again - any ideas/suggestions?

It sounds like this issue is popping up for some folks. May want to check the dev github for more answers, or they may need to create a hotfix

Link to post

I'm having an issue with some containers not running from a delugevpn stack. The error I get is: "Error response from daemon: no such container: XXXXX", where the XXXXX is a long string of numbers (too long to be a container ID).

 

This stack had been working fine for days but I had to update something in the delugevpn container so I reloaded it and now the rest of the containers won't work.

 

For reference, I've been running containers through the delugevpn container as a stack to route traffic in those containers through the VPN. At first it took a little work but I finally got it set up (I've attached my stack info for reference.) I currently have the following running through the VPN via this stack:

Sonarr

Radarr

Lidarr

NZBHydra

LibreSpeed

AirDCPP

 

Currently, AirDCPP and Lidarr were just commented out in my stack because I hadn't figured out how exactly to get those to work yet.

 

I tried commenting out the containers one at a time, e.g. the first one I tried was commenting out everything but delugevpn and nzbhydra, but I get the same error every time.

 

Host OS: FreeNAS

VM: RancherOS

 

I use Portainer for all my dockers for simplicity.

 

If anyone can shed some light on how to fix this, I would appreciate it!

delugestack.txt

Link to post
On 2/17/2021 at 1:57 AM, PeterB said:

Is anyone else using the AutoAdd plugin?

 

It used to work a treat for me but, sometime recently, it has stopped recognising new .torrent files.  I don't think I have changed any settings but, in any case, changing settings shouldn't stop it recognising new files entirely.

 

It cannot be an installation problem since AutoAdd is a 'standard' plugin - part of the Deluge distribution.

 

I would love to have it working again - any ideas/suggestions?

Occasionally a malformed file in the watch folders will break all watch folders, this has been more common since a lot of trackers have put additional captchas.

 

Anyway, look though your watch folders, delete anything that doesn't look like a .torrent file, then go back into AutoAdd and ensure the watch folders you have setup are still enabled.

Restart the container for good measure if it doesn't start picking up the files after making the changes.

Link to post
On 1/8/2021 at 10:55 AM, gergtreble said:

Thanks Binhex! 

 

I was not implicitly calling the :latest flag in my docker config. I just set that and refreshed. No packages changed so I guess I was already on latest. I'm still not able to seed and looking at the message in the tracker (attached) it seems they are seeing it as a 2.0.3 release, so the user agent switch is working. But they are still somehow able to notice its a dev version. Looks like they are using the 'peerid' to determine this? 

Screenshot 2021-01-08 at 09.50.18.png

 

Hi @gergtreble , @binhex

Did you guys find a solution to this issue in the mean time?

 

I'm also encountering this problem (with one of my private trackers, for the moment) and looking for a solution.

I'm open to debug, troubleshoot or help finding a practical solution for this.

Do you have a non-dev build-tag which I could use to run as a seperate instance for this tracker?

 

Thanks in advance!

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.