Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

3328 posts in this topic Last Reply

Recommended Posts

2 hours ago, gshlomi said:

Hi.

I've had an issue with a warning in Nextcloud security & setup warnings saying "our web server is not properly set up to resolve “/.well-known/webfinger”. Further information can be found in the documentation 12."

The solution was to add "rewrite ^/.well-known/webfinger /public.php?service=webfinger last;" to the /appdata/Nextcloud/nginx/site-confs/default file, in accordance with https://github.com/nextcloud/documentation/pull/877/files

Personaly I hate changing nginx configuration that came with the docker itself.

Is this a change that can be implemented in the container source?

 

 

Delete the default file and an updated default file will be created.

Share this post


Link to post
22 hours ago, Yak said:

Just so MothyTim doesn't feel alone,

 

I'm getting  similar issues. If I delete the default file and let nextcloud recreate it, I get a 502 error. If I then restore the original default file it's OK. However, if I then uncomment the "SAMEORIGIN" line I'm back to a 502 error.

 

I'm also getting the docker image filling up when anyone downloads a file

Hi, you seem to have a slightly different problem to mine, rebooting the machine fixed the errors I was getting, or enabled the files to be read correctly! Not sure why rebooting the dockers didn’t do that!

 

I’ve asked a couple of times and others have too about the docker image filling up and have never had an answer, so I guess no one knows! Odd behaviour though!

Share this post


Link to post

Pretty new here.

 

I have ran nextcloud with Ubuntu before with no issues like I am having now. 

I installed nextcloud through containers and the reverse proxy etc. The time it takes to load/transfer data is very slow. Also, bad gateway error constantly happens when trying to load larger video files. Seems to me the container installation of nextcloud is overall much slower. Any ideas on how to fix/trouble shoot?

Edited by Nozlo

Share this post


Link to post

Hi All, it's time for yet another request for help with adding external storage. I saw this topic has come up several times before in this thread and others, but none of the prior solutions worked for me. Thanks in advance for any help you can provide!

 

So, I'm trying to add a share called 'pictures' as an external storage within the Nextcloud container.

 

2.thumb.png.2ca7ad6906ed0b0b79966c2caeea26c4.png

1.thumb.png.9b41e3430def244e726811e58a292618.png

3.thumb.png.277dbd665919c3c1b9e1a9ce20528a43.png

4.png.befe707eaa455bb4639d88a1b2d44d9a.png

5.png.1ab3f1dbb54f7729a74dd787506b8b15.png

 

 

  • I checked that the workgroup is indeed WORKGROUP, as that is the same used by my windows PC. I'm able to connect/browse/edit the SMB share from my windows PC without any issue. Also tried it with the 'domain' field in Nextcloud simply being empty.
  • Currently the share is set to public, but I've tried it with Secure/Private as well.
  • I searched around in various Nextcloud/smb log files, but I couldn't find any log that gets generated from actually trying to create the external storage in Nextcloud? Other than the angry red circle. Is there anywhere I can look to see *why* the attempt to create the external storage failed?

 

I should add that I'm aware that you can mount the share within the Nextcloud container and add it as a Local external storage instead, but that's my last resort. I'd much prefer to get it working as an SMB external storage.

 

I appreciate any help anyone might be able to give!

Share this post


Link to post

Have a random Q; don’t believe it to be specific to Unraid but maybe someone here has seen this

Uploaded a file to NC and it has the time all borked. File says “uploaded 2 hours ago” immediately upon upload, but then activity shows minutes ago. Is this a NC problem, or a problem with the Client NC(iOS)?

Any ideas folks?

6b9cdea627b4dd9848050958d61c2f79.plist

Share this post


Link to post
On 11/17/2019 at 10:38 PM, Vaseer said:

Today I was uploading some files to my Nextcloud and one of them was 6 GB of size.
When I was uploading this file, I got email notice from unRAID server "Docker image disk utilization of 72%". When the upload finished, I got new email notice: "Docker image disk utilization returned to normal level".

 

This made me curious of how does file transfer or rather file write to Nextcloud storage works?
I always thought that files are written directly to Nextcloud HDDs. But it seems that files are initially stored to Nextcloud Docker instance which is on cache SDD and then written to Nextcloud storage HDDs.

 

Is this proper way for file transfer to Nextcloud or did I do something wrong with my configuration?

I didn't get any information (searched unRAID forum and Googled it) to answer this question so I am asking again and adding some new test results.

Uploading ~5GB test file to Nextcloud over local network:

Before upload:

BeforeUpload1.png.01d8eca908d4ee4b14f6f6b617a912f9.png BeforeUpload2.png.1cc95a0e4b0092acdaae111fd343b913.png

BeforeUpload3.png.4d6d92337513d75dece9303b15f5b0be.png

 

Couple seconds after finished upload:

SecondsAfterFinnishedUpload1.png.2206851fd4a0240ebe21732723c58ccf.png SecondsAfterFinnishedUpload2.png.b51ff2834e678cedbfe5ef9885db9e58.png

SecondsAfterFinnishedUpload3.png.0f55e23693d29e20b5bcce4d1bc89ef1.png

 

Is this normal/correct way of uploading files to Nextcloud?

NC container mappings:

/data <--> /mnt/disks/nextcloud/nextcloud-data/

/config <--> /mnt/cache/docker/appdata/nextcloud

 

unRAID version: 6.6.6

 

Edit: Found it!
This only happens when I upload files from my Fedora PC via webdav/dav connection (davs://vaseer@nc.mydomain.com/remote.php/webdav).
If I upload file via browser, docker.img size doesn't change.

Is this bug or expected behavior?

Edited by Vaseer

Share this post


Link to post
8 hours ago, Vaseer said:

I didn't get any information (searched unRAID forum and Googled it) to answer this question so I am asking again and adding some new test results.

Uploading ~5GB test file to Nextcloud over local network:

Before upload:

BeforeUpload1.png.01d8eca908d4ee4b14f6f6b617a912f9.png BeforeUpload2.png.1cc95a0e4b0092acdaae111fd343b913.png

BeforeUpload3.png.4d6d92337513d75dece9303b15f5b0be.png

 

Couple seconds after finished upload:

SecondsAfterFinnishedUpload1.png.2206851fd4a0240ebe21732723c58ccf.png SecondsAfterFinnishedUpload2.png.b51ff2834e678cedbfe5ef9885db9e58.png

SecondsAfterFinnishedUpload3.png.0f55e23693d29e20b5bcce4d1bc89ef1.png

 

Is this normal/correct way of uploading files to Nextcloud?

NC container mappings:

/data <--> /mnt/disks/nextcloud/nextcloud-data/

/config <--> /mnt/cache/docker/appdata/nextcloud

 

unRAID version: 6.6.6

 

Edit: Found it!
This only happens when I upload files from my Fedora PC via webdav/dav connection (davs://vaseer@nc.mydomain.com/remote.php/webdav).
If I upload file via browser, docker.img size doesn't change.

Is this bug or expected behavior?

That question is better asked to nextcloud. Nextcloud stores the file temporarily somewhere before writing it to disk and we have no control over where they choose to store it.

Might be stored in /tmp inside the container, so you could try to mount a folder to /tmp and see if it changes anything.

Do not mount unraid /tmp to /tmp inside the container as that might cause deleted files in tmp that shouldn't be deleted.

Share this post


Link to post

Is there any walkthrough on how to add new users, I followed the steps that spaceinvader one put up but it is only for one user. Other threads I have found online say there is a button to press to add new users, that is the one thing I can not find

Share this post


Link to post
3 hours ago, crash987_9 said:

Is there any walkthrough on how to add new users, I followed the steps that spaceinvader one put up but it is only for one user. Other threads I have found online say there is a button to press to add new users, that is the one thing I can not find

When you are in the user section there is a add new user button in the menu on the left. If you are on a mobile device that menu might be hidden. Click the sandwich button and it should appear.

Share this post


Link to post

Does anybody know why my downloads from my server via NextCloud would be so slow?

It only goes at about 25mbps and my ISP gives 940mbps.

It also times out every now and then and cancels downloads..

 

Thanks

Share this post


Link to post
9 minutes ago, Partial said:

Does anybody know why my downloads from my server via NextCloud would be so slow?

It only goes at about 25mbps and my ISP gives 940mbps.

It also times out every now and then and cancels downloads..

 

Thanks

You sure your upstream bandwidth is that high? Most ISP’s have a much slower upstream than downstream. For example mine is 150Mb down and 10Mb up.

Share this post


Link to post
4 minutes ago, Taddeusz said:

You sure your upstream bandwidth is that high? Most ISP’s have a much slower upstream than downstream. For example mine is 150Mb down and 10Mb up.

Yessir.

 

1.5gbps down and 940mbps up.

Granted I only use a gbit switch so I lose out on some of the dl speeds.

Share this post


Link to post
On 11/26/2019 at 6:57 PM, wombat said:

Hi All, it's time for yet another request for help with adding external storage. I saw this topic has come up several times before in this thread and others, but none of the prior solutions worked for me. Thanks in advance for any help you can provide!

 

So, I'm trying to add a share called 'pictures' as an external storage within the Nextcloud container.

 

2.thumb.png.2ca7ad6906ed0b0b79966c2caeea26c4.png

1.thumb.png.9b41e3430def244e726811e58a292618.png

3.thumb.png.277dbd665919c3c1b9e1a9ce20528a43.png

4.png.befe707eaa455bb4639d88a1b2d44d9a.png

5.png.1ab3f1dbb54f7729a74dd787506b8b15.png

 

 

  • I checked that the workgroup is indeed WORKGROUP, as that is the same used by my windows PC. I'm able to connect/browse/edit the SMB share from my windows PC without any issue. Also tried it with the 'domain' field in Nextcloud simply being empty.
  • Currently the share is set to public, but I've tried it with Secure/Private as well.
  • I searched around in various Nextcloud/smb log files, but I couldn't find any log that gets generated from actually trying to create the external storage in Nextcloud? Other than the angry red circle. Is there anywhere I can look to see *why* the attempt to create the external storage failed?

 

I should add that I'm aware that you can mount the share within the Nextcloud container and add it as a Local external storage instead, but that's my last resort. I'd much prefer to get it working as an SMB external storage.

 

I appreciate any help anyone might be able to give!

Hi,

 

i also have the same problem. Can someone help here? There are several post about this problem but no answer to it. 

 

I appreciate the awesome work that you are doing here. so i hope someone can help or make a how to video ^^

 

Thx

Share this post


Link to post

If it was posted my search skills didn’t turn it up...

 

When I set NC up initially I was dumb and did SQLite3 DB. I’m wanting to convert to a MariaDB. 
 

I see this page has the docker command fo convert but if I recall running commands in the Nextcloud docker is slightly different. Could someone enlighten me as to the correct command to run to convert to a MariaDB?

 

Nextcloud Article

Share this post


Link to post
2 hours ago, blaine07 said:

If it was posted my search skills didn’t turn it up...

 

When I set NC up initially I was dumb and did SQLite3 DB. I’m wanting to convert to a MariaDB. 
 

I see this page has the docker command fo convert but if I recall running commands in the Nextcloud docker is slightly different. Could someone enlighten me as to the correct command to run to convert to a MariaDB?

 

Nextcloud Article

I'd try with changing the "php occ" part of each command to "sudo -u abc php7 /config/www/nextcloud/occ".
That is unless you've changed your working directory to "/config/www/nextcloud/" with the command "cd /config/www/nextcloud/". Then you could use use "sudo -u abc php7 occ".

Edited by ICDeadPpl

Share this post


Link to post
On 12/4/2019 at 12:09 AM, ICDeadPpl said:

I'd try with changing the "php occ" part of each command to "sudo -u abc php7 /config/www/nextcloud/occ".
That is unless you've changed your working directory to "/config/www/nextcloud/" with the command "cd /config/www/nextcloud/". Then you could use use "sudo -u abc php7 occ".

I am assuming I would run the appropriate command while NextCloud is running, right?

Share this post


Link to post
6 minutes ago, blaine07 said:

I am assuming I would run the appropriate command while NextCloud is running, right?

You can't run the command if you can't get into the container. So yes, while it's running.

 

Share this post


Link to post
5 minutes ago, Nosirus said:

Someone succeeded with onlyoffice if so how?

I have it working. I have it set as a subdomain through the Let’s Encrypt Docker. I used their documentation on Nginx reverse proxy to get it working.

Share this post


Link to post
On 12/4/2019 at 12:09 AM, ICDeadPpl said:

I'd try with changing the "php occ" part of each command to "sudo -u abc php7 /config/www/nextcloud/occ".
That is unless you've changed your working directory to "/config/www/nextcloud/" with the command "cd /config/www/nextcloud/". Then you could use use "sudo -u abc php7 occ".

Well, successfully got this accomplished. Now in security warnings I have:

"MySQL is used as database but does not support 4-byte characters. To be able to handle 4-byte characters (like emojis) without issues in filenames or comments for example it is recommended to enable the 4-byte support in MySQL. For further details read the documentation page about this."

 

Which leads me THIS. Going to try to go through those motions a bit later today. Appears I'll flip this: "[mysqld] innodb_file_per_table=1" ON and then proceed to follow the MySQL steps at step 2 and restart and repair NextCloud etc. Hopefully it goes easy 🙂

Share this post


Link to post
2 hours ago, blaine07 said:

Well, successfully got this accomplished. Now in security warnings I have:

"MySQL is used as database but does not support 4-byte characters. To be able to handle 4-byte characters (like emojis) without issues in filenames or comments for example it is recommended to enable the 4-byte support in MySQL. For further details read the documentation page about this."

 

Which leads me THIS. Going to try to go through those motions a bit later today. Appears I'll flip this: "[mysqld] innodb_file_per_table=1" ON and then proceed to follow the MySQL steps at step 2 and restart and repair NextCloud etc. Hopefully it goes easy 🙂

Sometime it's the small things in life LOL; FINALLY got all this sorted out. Converted to SQL DB and got the silly security warnings ALL fixed.

 

"All checks passed."

 

Anyone else having Nextclouds Security check update the scan on their website? Says my scan was last done in October and I hit "trigger re-scan" hours ago and it still hasn't updated hmmm :shrug: oh well

Share this post


Link to post

I need help

I was testing Nextcloud, this morning.

I uninstalled, to start e new installation and configuration with MariaDB.

I never got the Nextcloud working again. I can't enter WebUI. Allays getting the error "Internal Server Error The server encountered an internal error and was unable to complete your request. Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report. More details can be found in the server log."

 

Can someone help me, please

Edited by karlus.p
correct word

Share this post


Link to post
5 minutes ago, karlus.p said:

I need help

I was testing Nextcloud, this morning.

I uninstalled, to start e new installation and configuration with MariaDB.

I never got the Nextcloud working again. I can't enter WebUI. Allays getting the error "Internal Server Error The server encountered an internal error and was unable to complete your request. Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report. More details can be found in the server log."

 

Can someone help me, please

Delete the appdata folder also if you want to start fresh. If you aren't using the database for anything else, it's probably best to nuke that one also, including its appdata folder.

Share this post


Link to post

Anyone have trips or tricks on backup Nextcloud and SQL DB or do you all just use the CA Baxkup/Restore plug-in solely?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.