[Support] ich777 - Gameserver Dockers

Recommended Posts

10 hours ago, ich777 said:

Give it a try I think, I've only run the server for a week but with two players on it it used only a little of CPU and when it was empty it idled between 0 to 2% CPU usage (back then I was using a Xeon 2670 v1 - keep in mind this is a old CPU).


What a coincidence, I have the exact same CPU! 


I guess I'll give it a shot. Thanks for putting this thread together btw! 

  • Like 1
Link to comment
12 hours ago, ich777 said:

I will look into this and report back.

Watchtower updated the container image last night and was able to successfully start up the container.  I have the FORCE_UPDATE flag set to true in my docker-compose.xml, so it all looks good now.


Thanks again ich777!  You do excellent work!


  • Like 1
Link to comment

Hi @ich777


currently i do give the ACCompetizione-Server a try. 

I just followed some instuctions and have it running. The Server also registered within the game, but as soon as i want to join my server i do get a connection could not be established notification.

Docker is running with Bridged Network und predefined port (9201) on Host's ip-address.

Router is configured to forward TCP&UDP for port 9201 to Host's IP-Address. 

Are there secific things to concider setting up? 


Best Felix 

Edited by morytox
Link to comment
3 minutes ago, morytox said:

Are there secific things to concider setting up? 

No, nothing else.


I really can't help here since this a game server that I did on request and I actually don't own the game, if you report it as broken I will deprecate it.


Have you looked into the Docker logs if the master server is actually able to connect to your server?

Link to comment

well, i started it with "Bridge" network settings. 

Could find it in the Online Server list but could not establish connection, but i also could not find it in the LAN-Servers list(?)

Changed network type to "Host"

Can now find it in LAN-Server list, can connect to it and use it (so server seems to work), but still cannot establish connection from internet. 

In this case it looks just like a networking issue, that there might be issues at FW level? But as long as i forward inbound Requests with the relevant port it should work fine i guess... 


Since you did it on demand, did you get any feedback from the requesting party? Maybe he can help?

Link to comment
1 hour ago, morytox said:

Since you did it on demand, did you get any feedback from the requesting party? Maybe he can help?

The container was working definitely, otherwise I won't release a container.


47 minutes ago, morytox said:

Your server works like a charm.

Glad that you've worked it out. :)

Link to comment

Hello @ich777,


Congrats for your hard work.


Please help me in Assetto Corsa Competizione Server

---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Checking if 'accServer.exe' is present---
---'accServer.exe' found, continuing...---
---Prepare Server---
---Checking if config files are present---
---Checking if WINE workdirectory is present---
---WINE workdirectory found---
---Checking if WINE is properly installed---
---WINE properly set up---
---Server ready---
---Start Server---
0009:err:mscoree:CLRRuntimeInfo_GetRuntimeHost Wine Mono is not installed


Server never found in game.

Link to comment

Heya @ich777

Project Zomboid just launched a new build 41 multiplayer test branch. I changed GAME_ID to 380870 -beta b41multiplayer. Now i'm getting errors and server don't start up fully. I've read from one of the devs that they use most recent GLIBC and thats why error appears. Is this something you need to know? Short reddit thread here on the matter: 



Link to comment
5 hours ago, jensrobot said:

Project Zomboid just launched a new build 41 multiplayer test branch. I changed GAME_ID to 380870 -beta b41multiplayer. Now i'm getting errors and server don't start up fully.

Container is now updated, please do a grafik.png.2c90403cef5510455a13b0e9a8af3363.png on the Docker page and it should work now. :)

  • Thanks 1
Link to comment
On 10/28/2021 at 5:25 PM, DazedAndConfused said:

Probably a dumb question, but how do I configure the container to use a custom domain? Do I just put it in the address field in the docker? 

I have configured it as another docker, but then in Cloudflare I configured it following mor or less this tutorial: https://www.youtube.com/watch?v=1HMHTQhuV9w

I use Nginx Proxy Manager for the reverse proxy and Cloudflare for the DNS.

Link to comment
3 minutes ago, Maurice97 said:

@ich777 I tried setting up a Teamspeak 3 Server via your Docker for me & friends but i can't seem to get the server out of the local network, even though i port forwarded all ports etc.

I have two TS3 Servers running and no issues whatsoever, please double check your port forwarding including the used protocol.


Have you changed anything?

Link to comment
4 minutes ago, Maurice97 said:

Cant explain why but after a reboot from my Unraid server i can cannot to the Ts3 Server

I think I don't understand because you've wrote "can cannot", do you mean "can connect" or do you mean "cannot connect".


If you have troubles can you please post a log output from the container or anything helpful? Otherwise I can't help.


Do you have a Cache driver installed? If yes make sure that the Use Cache setting at shares is set to "Only" or "Prefer".

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.