[support] limetech's docker repository


806 posts in this topic Last Reply

Recommended Posts

Strange, the only thing I Edited on plex was adding Paths to mounted Unassigned Devices, which now, ofcourse, are gone. I don't know what else happend.

Not sure about the UI problem (I and most users here use either Binhex or lsio's apps), but the UD path thing:

 

If its gone from the template, and you had to add the path in again then you didn't add the app back via CA's previous apps section which would have had that path in it (since it was the most recently saved template)

 

If nothing showed up within the app for the UD path, then you're running 6.1.9 in which case for UD paths you have to stop and restart the entire docker service (Settings - Docker) for it to recognize anything within a UD path.  Under 6.2 you set the mode instead of RW to be RW:Slave to avoid that issue.

Link to post
  • Replies 805
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Here is a video showing how to move from the deprecated Limetech plex container to either Linuxserver's, Binhex's or the official plex container.    

Howdy folks, this is the support thread for the LimeTech maintained Docker repository: https://github.com/limetech/docker-templates   Docker containers included:  Plex Media Server

I know this will not be very helpful, but, like Squid, I have always used /mnt/user/appdata for Plex and other dockers and have never had any Plex/SQLite database corruption.  I have been running unRA

Posted Images

  • 3 weeks later...

I'm having a lot of problems with Plex from the limetech repository.  Every time I go into the console it says there's an update available but checking the Docker container doesn't show one.  Streaming to my Rokus and XBox One has stopped working, through other devices like my iPads are ok.  I can move to a different repository and a different version but man do I NOT want to lose all my customizations, etc;  Is there a way to make that not happen?  Or a way to fix the existing?

Link to post

I'm having a lot of problems with Plex from the limetech repository.  Every time I go into the console it says there's an update available but checking the Docker container doesn't show one.  Streaming to my Rokus and XBox One has stopped working, through other devices like my iPads are ok.  I can move to a different repository and a different version but man do I NOT want to lose all my customizations, etc;  Is there a way to make that not happen?  Or a way to fix the existing?

Please try this: 

On the unRAID web UI go to the Docker page. Toggle on Advanced view (near the top right of the page) and click the 'force update' link for Plex.

Link to post
  • 2 weeks later...

Anyone have an ETA on when (if) the latest versions of Plex will be incorporated into this Docker?  My Plex has been wanting me to upgrade for a couple months.  Is this something we can do in the docker itself - or - do we need to wait on Limetech to update the docker?

 

width=300http://my.jetscreenshot.com/12412/20160913-iqhn-47kb.jpg[/img]

 

Thanks in advance!

 

 

Link to post

Anyone have an ETA on when (if) the latest versions of Plex will be incorporated into this Docker?  My Plex has been wanting me to upgrade for a couple months.  Is this something we can do in the docker itself - or - do we need to wait on Limetech to update the docker?

 

width=300http://my.jetscreenshot.com/12412/20160913-iqhn-47kb.jpg[/img]

 

Thanks in advance!

LSIO plex docker probably gets more frequent updates than this one. It is pretty easy to switch. Just backup your appdata then just use the same volume mappings for LSIO plex docker and everything should just work. If you're plexpass you can even use the plexpass DVR beta. See the LSIO plex docker thread.
Link to post

Anyone have an ETA on when (if) the latest versions of Plex will be incorporated into this Docker?  My Plex has been wanting me to upgrade for a couple months.  Is this something we can do in the docker itself - or - do we need to wait on Limetech to update the docker?

 

width=300http://my.jetscreenshot.com/12412/20160913-iqhn-47kb.jpg[/img]

 

Thanks in advance!

 

I second that question!

Link to post

And a third. I've asked this same question in another post and never received a response. Also, I don't really want to go to the trouble of changing dockers to another one for Plex. I know I could for one that is updated more often, but I actually chose this one since it appeared to be one of the standard ones that I thought would receive any needed updates.

 

This type of thing isn't the end of the world since Plex still seems to be functioning well, but I feel like I might be missing something when I constantly see the banner that an update is available. :)

Link to post

Anyone have an ETA on when (if) the latest versions of Plex will be incorporated into this Docker?  My Plex has been wanting me to upgrade for a couple months.  Is this something we can do in the docker itself - or - do we need to wait on Limetech to update the docker?

 

width=300http://my.jetscreenshot.com/12412/20160913-iqhn-47kb.jpg[/img]

 

Thanks in advance!

 

I second that question!

Have you tried advanced view -> force update from the docker page?

Link to post

Anyone have an ETA on when (if) the latest versions of Plex will be incorporated into this Docker?  My Plex has been wanting me to upgrade for a couple months.  Is this something we can do in the docker itself - or - do we need to wait on Limetech to update the docker?

 

width=300http://my.jetscreenshot.com/12412/20160913-iqhn-47kb.jpg[/img]

 

Thanks in advance!

 

I second that question!

Have you tried advanced view -> force update from the docker page?

 

Oh wow. I didn't even know that option was there. It seems to have worked for me. At least the notification is no longer there in Plex. Thanks for this.

Link to post

Hi,

 

Did a check for updates under docker and tried to update my Limetech Plex docker and got the following error. Any ideas? I am running unraid 6.2 and plex is at version 1.1.3.2700.

 

----------8<----------

 

Pulling image: limetech/plex:latest

IMAGE ID [latest]: Pulling from limetech/plex.

IMAGE ID [6ffe5d2d6a97]: Already exists.

IMAGE ID [f4e00f994fd4]: Already exists.

IMAGE ID [e99f3d1fc87b]: Already exists.

IMAGE ID [a3ed95caeb02]: Already exists.

IMAGE ID [ededd75b6753]: Already exists.

IMAGE ID [1ddde157dd31]: Already exists.

IMAGE ID [79321844ebba]: Pulling fs layer. Downloading 100% of 772 B. Verifying Checksum. Download complete. Extracting. Pull complete.

IMAGE ID [ebe499b4c161]: Pulling fs layer. Downloading 100% of 119 MB. Verifying Checksum. Download complete. Extracting. Pull complete.

IMAGE ID [cb387480a3c1]: Pulling fs layer. Downloading 100% of 561 B. Verifying Checksum. Download complete. Extracting. Pull complete.

 

TOTAL DATA PULLED: 119 MB

 

Error: layers from manifest don't match image configuration

 

----------8<----------

 

Thanks

Jim

Link to post

Hi,

 

Did a check for updates under docker and tried to update my Limetech Plex docker and got the following error. Any ideas? I am running unraid 6.2 and plex is at version 1.1.3.2700.

 

----------8<----------

 

Pulling image: limetech/plex:latest

IMAGE ID [latest]: Pulling from limetech/plex.

IMAGE ID [6ffe5d2d6a97]: Already exists.

IMAGE ID [f4e00f994fd4]: Already exists.

IMAGE ID [e99f3d1fc87b]: Already exists.

IMAGE ID [a3ed95caeb02]: Already exists.

IMAGE ID [ededd75b6753]: Already exists.

IMAGE ID [1ddde157dd31]: Already exists.

IMAGE ID [79321844ebba]: Pulling fs layer. Downloading 100% of 772 B. Verifying Checksum. Download complete. Extracting. Pull complete.

IMAGE ID [ebe499b4c161]: Pulling fs layer. Downloading 100% of 119 MB. Verifying Checksum. Download complete. Extracting. Pull complete.

IMAGE ID [cb387480a3c1]: Pulling fs layer. Downloading 100% of 561 B. Verifying Checksum. Download complete. Extracting. Pull complete.

 

TOTAL DATA PULLED: 119 MB

 

Error: layers from manifest don't match image configuration

 

----------8<----------

 

Thanks

Jim

 

Same here...

Link to post

Hi,

 

Did a check for updates under docker and tried to update my Limetech Plex docker and got the following error. Any ideas? I am running unraid 6.2 and plex is at version 1.1.3.2700.

 

----------8<----------

 

Pulling image: limetech/plex:latest

IMAGE ID [latest]: Pulling from limetech/plex.

IMAGE ID [6ffe5d2d6a97]: Already exists.

IMAGE ID [f4e00f994fd4]: Already exists.

IMAGE ID [e99f3d1fc87b]: Already exists.

IMAGE ID [a3ed95caeb02]: Already exists.

IMAGE ID [ededd75b6753]: Already exists.

IMAGE ID [1ddde157dd31]: Already exists.

IMAGE ID [79321844ebba]: Pulling fs layer. Downloading 100% of 772 B. Verifying Checksum. Download complete. Extracting. Pull complete.

IMAGE ID [ebe499b4c161]: Pulling fs layer. Downloading 100% of 119 MB. Verifying Checksum. Download complete. Extracting. Pull complete.

IMAGE ID [cb387480a3c1]: Pulling fs layer. Downloading 100% of 561 B. Verifying Checksum. Download complete. Extracting. Pull complete.

 

TOTAL DATA PULLED: 119 MB

 

Error: layers from manifest don't match image configuration

 

----------8<----------

 

Thanks

Jim

 

Same here...

https://lime-technology.com/forum/index.php?topic=40937.msg481138#msg481138

Link to post

I am getting the same error after updating to Unraid 6.2. I read that removing the app and re-installing it would help, but now I am getting the same error when trying to re-install it from the community apps page. I am kinda getting worried since I put a lot of effort into maintaining the Plex server's database. I hope that removing the docker image didn't nuke the whole thing.

 

Thanks,

Carsten

Link to post

Can anyone help me figure out why the limetech-plex docker would keep crashing and filling up my RAM until the server becomes unresponsive?  In the course of 5 minutes, this docker will fill up 10% of my available memory, completely maxing it out in less than a half hour.  Here's the log file:

 

terminate called after throwing an instance of 'soci::soci_error'

what(): Cannot begin transaction. attempt to write a readonly database

****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Library/Application Support/Plex Media Server/Crash Reports/1.1.4.2757-24ffd60/PLEX MEDIA SERVER/36c0e4b2-9444-8210-79eb7ce5-76543360.dmp

Aborted

6 10000 /config/Library/Application Support

10000

terminate called after throwing an instance of 'soci::soci_error'

what(): Cannot begin transaction. attempt to write a readonly database

****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Library/Application Support/Plex Media Server/Crash Reports/1.1.4.2757-24ffd60/PLEX MEDIA SERVER/4c8162bc-c79b-46bb-2dbf644f-0e0efaac.dmp

Aborted

6 10000 /config/Library/Application Support

10000

terminate called after throwing an instance of 'soci::soci_error'

what(): Cannot begin transaction. attempt to write a readonly database

****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Library/Application Support/Plex Media Server/Crash Reports/1.1.4.2757-24ffd60/PLEX MEDIA SERVER/33b5ddc2-98f4-7b1d-37cd0272-6d0ba720.dmp

Aborted

6 10000 /config/Library/Application Support

10000

terminate called after throwing an instance of 'soci::soci_error'

what(): Cannot begin transaction. attempt to write a readonly database

****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Library/Application Support/Plex Media Server/Crash Reports/1.1.4.2757-24ffd60/PLEX MEDIA SERVER/5bb63706-173a-ab29-42d06c81-4d4cf299.dmp

Aborted

6 10000 /config/Library/Application Support

10000

terminate called after throwing an instance of 'soci::soci_error'

what(): Cannot begin transaction. attempt to write a readonly database

****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Library/Application Support/Plex Media Server/Crash Reports/1.1.4.2757-24ffd60/PLEX MEDIA SERVER/71677bb8-f11c-9639-76934dad-6458b73a.dmp

Aborted

6 10000 /config/Library/Application Support

10000

terminate called after throwing an instance of 'soci::soci_error'

what(): Cannot begin transaction. attempt to write a readonly database

****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Library/Application Support/Plex Media Server/Crash Reports/1.1.4.2757-24ffd60/PLEX MEDIA SERVER/3cdf3145-f687-6606-6eadd2f1-14ab79ad.dmp

Aborted

6 10000 /config/Library/Application Support

10000

 

Note that is just a small sample of the whole log file.  Here's the run command:

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="PlexMediaServer" --net="host" --privileged="true" -e TZ="America/New_York" -e HOST_OS="unRAID" -v "/mnt/cache/appdata/plexmediaserver/":"/config":rw -v "/mnt/user/Media/Movies/":"/Movies":rw -v "/mnt/user/Media/Music/":"/Music":rw -v "/mnt/user/Media/TV/":"/TV":rw limetech/plex

7935be23a4ccf35f3eb8839ea52d3f61fb8f689fb716c8055963c901fbb16039

 

The attached picture shows the top 20 processes in RAM after about 20 minutes.  Just a little bit longer and my whole server will become unresponsive.

2016-09-18_01_44_05-Tower_Dashboard.png.47cb27cc698d44e20e371ac405c73b33.png

Link to post

Read the faq entry.  Nothing to worry about

 

 

Sent from my SM-T560NU using Tapatalk

 

there's a better fix:

this post: https://github.com/docker/distribution/issues/1439#issuecomment-237999672

 

has the fix which worked perfectly for me without having to reinstall everything...

The existing layers may be an important piece of the puzzle. I think what's happening is that one of the existing layers was downloaded by an older version of Docker that did not save tar-split metadata. The migration to content-addressability computed an ID for the layer, but this doesn't match the ID that comes directly from the tar. The migration also prepopulated the mapping between the layer digest and the artifact digest in

/var/lib/docker/image/*/distribution

. Pulling another image that uses the affected layer will try to use this layer digest from the migration, but that digest turns out to be wrong, so the pull fails.

 

If this is correct, deleting

/var/lib/docker/image/*/distribution

should fix your problem pulling maxpowa/npomf:latest. This is just a cache, so it should be safe to remove (removing it will just cause extra data to be transfered during pushes and pulls until the cache is repopulated).

Link to post

Unable to update Sync docker after updating to unRAID 6.2

 

Error: layers from manifest don't match image configuration

Check out either the docker FAQ or the 2nd post in the 6.2 announcement

 

Sent from my LG-D852 using Tapatalk

 

Link to post
  • 2 weeks later...

I'm considering start using BT Sync (Resilio) as an alternative to all the limited capacity cloud solutions, but I'm not 100% sure if the support within unRAID is active :(. unRAID could be a really nice platform to use it, having the server as an "always on" peer to share the files to the clients, but I cannot find a docker with active development. There're some other dockers like Plex where the updates are automatic within the docker. Could it be done the same way within unRAID?

 

This official docker seems to be outdated, and the others I found using Community Apps have the same problem :(

 

Any tips about its stability, reliability or alternatives?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.