Jump to content
limetech

Unraid OS version 6.8 available

254 posts in this topic Last Reply

Recommended Posts

5 hours ago, J.Nerdy said:

My log is getting crushed with:

 

CIFS VFS: SMB signature verification returned error = - 5 

 

Does this have to do with new SMB protocol?

 

Edit: Diag attached

nerdyraid-diagnostics-20191213-0017.zip 150.46 kB · 1 download

This is from the remote mount you have in UD.  CIFS is the network protocol used to connect to the remote mount.  I suspect it may be from your remote mount having credentials.  Post this in the UD forum for further help.

Share this post


Link to post

I think I just wait for the 5.9-rc1, I'm on ryzen, I need 5.4 kernel to test ECC

Edited by trott

Share this post


Link to post

How long is the upgrade expected to take, I'm currently runnig 6.7.2, and no VMs or dockers?

Share this post


Link to post
10 minutes ago, gberg said:

How long is the upgrade expected to take, I'm currently runnig 6.7.2, and no VMs or dockers?

You download it and reboot.  That's all there is to it.

Share this post


Link to post
1 hour ago, dlandon said:

This is from the remote mount you have in UD.  CIFS is the network protocol used to connect to the remote mount.  I suspect it may be from your remote mount having credentials.  Post this in the UD forum for further help.

Will do, thank you

Share this post


Link to post
1 hour ago, CHBMB said:

You download it and reboot.  That's all there is to it.

 

Well, that went smooth, and now the even the case model custom image was there after the reboot, great!!!

Share this post


Link to post

Updated this morning.

 

System totally locked up after about 10 mins.

 

Nothing in the console or flash drive syslog.

 

Forced a reboot - everything ok 8 hours later so hoping it is a one off!

Edited by Interstellar

Share this post


Link to post

After my previous glowing report, I've noticed a small glitch. On the dashboard, several of the sections won't expand, for example:

962680770_2019-12-1310_53_57-NAS_Dashboard-Brave.png.0df316a02243f611b66d4261de3e2c8f.png

Clicking the down chevrons there has no effect. I can click the gears and it will go to the appropriate settings page, but no response to the chevrons. 

 

In addition to the three shown in the image, this is happening on these sections:

* Main server (top left item)

* Motherboard

* Power

* Airflow

 

None of these are items that I normally have expanded and they were collapsed on 6.7.2 before I started the upgrade. The only one that wasn't expanded prior to the upgrade that does work now is the VPN section - it didn't exist under 6.7.2.

nas-diagnostics-20191213-1100.zip

 

Share this post


Link to post
13 minutes ago, FreeMan said:

After my previous glowing report, I've noticed a small glitch. On the dashboard, several of the sections won't expand, for example:

What browser did you use? Any ad blocker?

I tested on Chrome and Firefox and have no problem at all.

Share this post


Link to post
7 minutes ago, testdasi said:

What browser did you use? Any ad blocker?

I tested on Chrome and Firefox and have no problem at all.

Excellent point!

 

I'm using Brave with "Shields" down. I just tested on both Chrome and FF and also had no issue. Very interesting... :/ Brave is supposed to be built on the latest version of Chromium (minus all the tracking "features" built in by Google).

 

TBH- this isn't a showstopper for me that will prevent me from using Brave. The items that won't expand are ones I almost never look at and if I do need to see them, I'll go look at the specific menus.

 

 Carry on, nothing significant to see here, though it may be an additional testing point for @bonienl for future releases.

Edited by FreeMan

Share this post


Link to post
On 12/10/2019 at 5:31 PM, limetech said:

WireGuard® support - available as a plugin via Community Apps.  Our WireGuard implementation and UI is still a work-in-process; 

Will Wireguard eventually be integrated into unRAID? I think Wireguard is very cool and definitely appreciate the work on new functionalities, but am curious about the design decision here. It's unrelated to storage (and I would personally hesitate to host my VPN server on my storage server in case I need to reboot my storage remotely). Wireguard can also be run as a docker container if the kernel supports (here's a popular one: https://github.com/cmulk/wireguard-docker). The Plugin/Community App/Docker route may be cleaner and less demanding on developer resources.

Share this post


Link to post
18 minutes ago, golli53 said:

It's unrelated to storage

So are Docker apps, so are VM's...

 

WireGuard indeed will be integrated in a future release.  There are two reasons we've kept the UI as a plugin for now.  First, as a plugin, the UI can be developed independent of Unraid OS releases as we gain more experience with various use cases for WG.  Second, WG is still marked work-in-progress and as such we don't want to imply it's 100% trusted and tested by direct inclusion in Unraid OS.  I use WG every day for remote backup.

  • Like 1
  • Thanks 1

Share this post


Link to post

After upgrading to 6.8 I'm now getting this noVNC error while trying to access both vms I run.

 

noVNC encountered an error:

 

Uncaught SyntaxError: The requested module './util/browser.js' does not provide an export named 'dragThreshold'

http://192.168.1.4/plugins/dynamix.vm.manager/vnc.html?autoconnect=true&host=192.168.1.4&port=&path=/wsproxy/5700/:0:0

SyntaxError: The requested module './util/browser.js' does not provide an export named 'dragThreshold'

 

I can access the vms just fine with NoMachine and Remmina but not the VNC Remote menu option in Unraid.

Share this post


Link to post
57 minutes ago, golli53 said:

 I would personally hesitate to host my VPN server on my storage server in case I need to reboot my storage remotely

I saw a link to this guy's site one one of the WireGuard install or support threads (don't recall which at the moment - I've been reading a fair bit). That links to another page on his site about setting up for being on vacation, including having multiple ways of sending a WOL packet to get the server back up and running should it be shut down by the UPS when the power goes out. Plus, plugins auto start when the server boots, so once it's rebooted, you'll have your VPN back.

Share this post


Link to post

The implementation of WireGuard on Unraid, allows VPN access even when the array is not started. And remote access is almost instantly available after reboot.

This is a huge advantage as compared to WireGuard running in a docker container, which is only possible when the array is up and running and all services are correctly started.

  • Like 2
  • Thanks 1

Share this post


Link to post
13 minutes ago, FlynDice said:

After upgrading to 6.8 I'm now getting this noVNC error while trying to access both vms I run.

 

noVNC encountered an error:

 

Uncaught SyntaxError: The requested module './util/browser.js' does not provide an export named 'dragThreshold'

http://192.168.1.4/plugins/dynamix.vm.manager/vnc.html?autoconnect=true&host=192.168.1.4&port=&path=/wsproxy/5700/:0:0

SyntaxError: The requested module './util/browser.js' does not provide an export named 'dragThreshold'

 

I can access the vms just fine with NoMachine and Remmina but not the VNC Remote menu option in Unraid.

Try the following:

1. Stop the VM(s)

2. Go to the edit page of the VM(s) and press "Update" (this forces VNC to re-apply the VNC port)

3. Start the VM(s) and try to access using VNC

Share this post


Link to post
44 minutes ago, bonienl said:

Try the following:

1. Stop the VM(s)

2. Go to the edit page of the VM(s) and press "Update" (this forces VNC to re-apply the VNC port)

3. Start the VM(s) and try to access using VNC

 Unfortunately no difference.

 

Update:

 

I restored to 6.7.2 and ended up with the same problem.

 

After clearing the browser cache noVNC access to the vms was normal in both 6.72 and 6.8  😁

Edited by FlynDice
More info/Problem solved

Share this post


Link to post

Have you tried a VNC client that is not noVNC based (e.g. something like realVNC)?  If that works then it at least pinpoints the problem as being the noVNC client and not something else.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.