Unraid OS version 6.8.2 available


limetech

110 posts in this topic Last Reply

Recommended Posts

  • Replies 109
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Due to a security vulnerability discovered in forms-based authentication:   ALL USERS ARE STRONGLY ENCOURAGED TO UPGRADE   To upgrade: If you are running any 6.4 or later r

remotely connected using wireguard, from my phone upgraded 6.8.1 to 6.8.2 without error. thank you unraid team!

FYI: We've released a security tips and best practices blog alongside this release. TIA for reading!

Posted Images

Yes I do have a UPS. None of the clocks in my house are reset so I don't think it was power related. I'll keep an eye on the logs to see if anything else weird happens. Is this user script the best way to capture logs leading up to a crash?

 

#!/bin/bash

mkdir -p /boot/logs
FILENAME="/boot/logs/syslog-$(date +%s)"
tail -f /var/log/syslog > $FILENAME

 

Link to post
20 minutes ago, johnsanc said:

Yes I do have a UPS. None of the clocks in my house are reset so I don't think it was power related. I'll keep an eye on the logs to see if anything else weird happens. Is this user script the best way to capture logs leading up to a crash?

 


#!/bin/bash

mkdir -p /boot/logs
FILENAME="/boot/logs/syslog-$(date +%s)"
tail -f /var/log/syslog > $FILENAME

 

Probably better is this option that is available in current Unraid releases.

Link to post

updated from 6.7.2 to 6.8.2, unable to start array.

array tab just shows reboot or shutdown, looking at logs:

Jan 28 18:24:02 husky emhttpd: error: mdcmd, 2721: Device or resource busy (16): write
Jan 28 18:24:02 husky kernel: mdcmd (47): stop 
Jan 28 18:24:02 husky kernel: md: 1 devices still in use.

 

husky-diagnostics-20200128-1832.zip

 

thinking it may be the recent security change...

 

removing this line from my go file and rebooting:

cp /boot/custom/docker-shell /usr/local/bin

looks like that was the culprit... went and and just deleted this script since it's not really needed (was checking it out from a spaceinvader video)

 

I know in the 6.8 notes it mentioned about the go entries no longer having the +x bit and you'd have to copy the files off.. but why did this kill the array from being able to boot? or was it just some fluke (I do not have array auto start enabled)

Edited by zoggy
Link to post

I updated two of my three servers. On one, the VM Manager was set to disabled after the reboot. No apparent loss after re-enabling which is fortunate because I have ten custom tweaked VM's that I would find unpleasant to redo that work. On the other machine, a VM that had vanished sometime in the past was now available after the reboot.

 

So, what's the best way to back up the VM settings? Stopping the array and backing up /mnt/user/system/libvirt/libvirt.img ?

Link to post
7 hours ago, jbartlett said:

I updated two of my three servers. On one, the VM Manager was set to disabled after the reboot. No apparent loss after re-enabling which is fortunate because I have ten custom tweaked VM's that I would find unpleasant to redo that work. On the other machine, a VM that had vanished sometime in the past was now available after the reboot.

 

So, what's the best way to back up the VM settings? Stopping the array and backing up /mnt/user/system/libvirt/libvirt.img ?

I've had this problem with earlier releases when changing other configuration options. Never really did figure it out, but it never seemed to happen when I wasn't messing with things so I wasn't to worried about it. In my case I never seemed to lose anything, just an annoyance since I had to reboot after re-enabling.

Link to post
2 hours ago, SpecFroce said:

My W10 VM refuses to boot. It freezes during startup. This was not a issue in the previous version. 

I haven't had this particular issue but one of my first troubleshooting steps is to create another VM using the same settings. Sometimes, something gets funged up in the XML that isn't visible in the GUI and it isn't obvious if you aren't intimately familiar with every part of the XML.

Link to post
  • limetech unfeatured and unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.