Strom sparen mit powertop / Stromverbrauch von UnRaid verbessern


Recommended Posts

Bin mal neugierig. Mit ist aufgefallen dass seit meinem Update von 6.11.5 auf 6.12.4 mein Messgerät nen ~1 Watt höheren verbrauch meldet. Kann das jemand bestätigen? Hab das gerade nochmal nachgeguckt und bei 6.11.5 komm ich auf 14.4 - 14.9 Wattbereich wenn nix außer 1 Docker Container läuft und bei 6.12.4 ist es 15.3-16.1 Watt.

Bei "Semi-Last" war ich bei knapp unter 20 Watt unter 6.12.4 und bei 6.11.5 ist es 17.3-17.7 Watt

Link to comment
40 minutes ago, EL-Diablo said:

kann es sein das der Befehl auto-tune zu solchen fehler führen kann?

ja.

Wenn der zugehörende Festplattenkontroller es nicht korrekt verträgt in einen dieser niedrigen Powerzustände versetzt zu werden dann spinnt der rum.

Hatte ich auch schon mal vor mehr als 1 Jahr.

 

Link to comment
1 hour ago, EL-Diablo said:

ich glaube ja, das der USB Controler in schlaf geht und das unraid nicht ab kann, was ja logisch ist.

Nur weis ich dann nicht wie man das verhindert.

Sind die Festplatten per USB angebunden?

Das ist bei unraid nicht die zu bevorzugende Methode.

 

Wie Du verhindern kannst, daß der Kontroller per powertop -autotune beeinflußt wird?

Nutze -autotune einfach nicht.

Diverse der Powereinstellungen sind auch ohne autotune möglich. -autotjn emacht es eben nur einfacher.

 

Link to comment
5 hours ago, EL-Diablo said:

nein, sind nicht USB angebunden, sda ist der USB Stick.

 

Wie kann man es Manuell einstellen?

zumal nervt micht, das ich nach jeden reboot ich neu einstellen müsste.

 

Okay, ich hatte vergleichbare Probleme mit Festplatten im Array (SATA).

 

Hilfen zu Powertop finden sich im Netz recht viele.

https://wiki.archlinux.org/title/powertop

https://manpages.ubuntu.com/manpages/xenial/man8/powertop.8.html

https://wiki.ubuntuusers.de/PowerTOP/

Zu Deinem Problem vielleicht passend find eich dort:

"...Beispielsweise werden mit "--auto-tune" auch USB-Geräte wie Maus und Tastatur auf minimalen Energieverbrauch optimiert, was zu Nutzungsverzögerungen führen kann..."

 

Wenn Du die passenden Parameter für Deine Nutzung gefunden hast mußt Du es nicht bei jedem Booten neu einstellen, dann pack das in das Go File.

 

In dieser Diskussion (und auch in dem anfänglich englischsprachigen Teil) ist so einiges beschreiben.

@mgutt scheint sich ja damit sehr gut auszukennen und hat auch mal ein Beispiel für das GoFile dargestellt.

Ich bin da eher noch blutiger Anfänger.

 

Link to comment
On 9/7/2023 at 5:20 PM, Mainfrezzer said:

Mhmm mysteriös. Da werde ich mich wohl auf die Suche begeben müssen was da nen Furz quer sitzen hat.

Dankeschön

Hab alles mögliche versucht. Die einzige Variabel ist tatsächlich Unraid selbst. Mal gucken ob's futsch ist in der Zukunft. Bin in der Zwischenzeit wieder auf 11.5 gewechselt. Läppert sich ja das blöde Watt bei der kleinen Gesamtmenge. Könnt natürlich mal gucken ob das an der Plattform liegen könnte, müsst dann aber mal schauen wann ich länger den Server offline nehmen könnte damit ich 'nen anderen Rechner ans Messgerät hängen kann.


Update:
Kurios. Ich habe es mal mit ner Haswell Platform versucht. Da war der Verbrauch tatsächlich bei 6.12.4 niedriger im vergleich mit 6.11.5.

Edited by Mainfrezzer
Link to comment
  • 3 weeks later...
  • 2 weeks later...

Hallo,

 

ich bin gerade dabei meinen Stromverbrauch am Server zu reduzieren und schaffe es nicht das das ich in eine höheren Cstate als 2 komme!

 

Derzeitiger Stromverbrauch ist 100Watt im Idle (gemessen von Shelly) bei einer CPU Auslastung von ca 1-5%

 

Hat jemand eine Idee was ich noch versuchen könnte.

 

Hardware :

Mainboard: Asus Proart z790

CPU Intel 13900k

Ram: 128Gb Kingston Fury

Netzteil: Bequit 650Watt Platinium

 

 

Vielen Dank im Voraus .


Hier noch einige Screenshots:IMG_0015.thumb.jpeg.98b9987f25708bc0091d039aac4aaafb.jpeg

 

 

IMG_0016.thumb.jpeg.1e3bffcfc3575665a1d1af63db3c7eeb.jpeg
IMG_0020.thumb.jpeg.d4a816228830ecc9d9f84482ada4463f.jpeg

Link to comment
22 minutes ago, Patzi said:

Derzeitiger Stromverbrauch ist 100Watt im Idle (gemessen von Shelly) bei einer CPU Auslastung von ca 1-5%

...

Hardware :

Mainboard: Asus Proart z790

CPU Intel 13900k

Ram: 128Gb Kingston Fury

Netzteil: Bequit 650Watt Platinium

100W Idle? Drehen die Festplatten oder hast Du zumindest die in den Spindown geschickt?

Link to comment
1 minute ago, DataCollector said:

100W Idle? Drehen die Festplatten oder hast Du zumindest die in den Spindown geschickt?

Festplatten sind spindown

 

Ein Pool mit 2stk 2tb Nvme Ssd ist aktiv!

 

Vm läuft da auch keine !

 

Nur 3 Docker Container aber wenn ich die auch Herunterfahre ist kein merkbarer Unterschied ersichtlich

Link to comment
51 minutes ago, Patzi said:

Vm läuft da auch keine !

Nur 3 Docker Container aber wenn ich die auch Herunterfahre ist kein merkbarer Unterschied ersichtlich

 

Wenn also alle Festplatten im Spindown sind und Du idle dennoch 100W verballerst ist irgendetwas nicht okay.

Du hast zwar jetzt nicht unbedingt sparsame Komponenten, aber idle und spindown würde ich schon unter 60W vermuten.

 

Wenn ich mir die paar spärlichen Screenshots so ansehe:

Bist Du sicher, daß Du Speedstep und Speedshift disabled haben willst?

 

Ich vermute mal anhand Deiner Kurzbeschreibung, daß Du folgendes Mainboard einsetzt:
ASUS ProArt Z790-Creator WIFI (90MB1DV0-M0EAY0 / 90MB1DV0-M1EAY0)

 

Hast Du den WiFi Krempel abgeschaltet?

 

Da Du vermutlich die maximale PCIE 5.0 Geschwindigkeit nicht brauchst: Hast Du mal im BIOS/UEFi geschaut ob Du PCIe auf 3.0 reduzieren kannst?


Läßt sich der CPU Verbrauch deckeln?


10GBLan schluckt auch einiges an Strom. benutzt Du das ueberhaupt oder kannst Du es abschalten?


Thunderbolt ist auch recht stromintensiv. benutzt Du es oder kannst Du es abschalten?


Ist das ganze AI-Overclocking Zeugs abgeschaltet?

Edited by DataCollector
EDIT - Diverse Infos zu dem Mainboard gelistet
Link to comment
18 minutes ago, DataCollector said:

 

Wenn also alle Festplatten im Spindown sind und Du idle dennoch 100W verballerst ist irgendetwas nicht okay.

Du hast zwar jetzt nicht unbedingt sparsame Komponenten, aber idle und spindown würde ich schon unter 60W vermuten.

 

Wenn ich mir die paar spärlichen Screenshots so ansehe:

Bist Du sicher, daß Du Speedstep und Speedshift disabled haben willst?

 

Das mit den Komponenten weis ich aber benötige die Leistung manchmal für die Vms!

 

Trotzdem habe ich mir erhofft irgendwo in die Richtung 50w Idle zu kommen!

 

Funktionieren diese Optionen unter Unraid problemlos hab mir gedacht sind für windows abgestimmt?

 

 

 

Wifi Thunderbolt Bluetooth CPU overclocking alles aus!

 

PCIE 5.0 und LAN10gb würde ich gerne behalten!

Haben die 2 Sachen Auswirkung auf die Cstates?

 

 

CPU Verbrauch deckeln hätte ich nicht gesehen nur das ich die Powerkerne abschalten könnte!

 

Edited by Patzi
Link to comment
2 hours ago, Patzi said:

Derzeitiger Stromverbrauch ist 100Watt im Idle (gemessen von Shelly) bei einer CPU Auslastung von ca 1-5%

Puh, das ist schon viel zu viel.

 

31 minutes ago, Patzi said:

Speedstep und Speedshift eingeschalten hat sich der Stromverbrauch jetzt um 7Watt verringert!

Das noch immer...

 

Mein System in dieser config hat gerade mal 70 bis 75W verbraucht im Idle mit 1x HDD, 2x SSD & 2x NVME aktiv:

 

Ich hab jetzt aber fast keine Addon Karten mehr drin dafür 1 SSD mehr und bin jetzt auf ca. 50 - 55W im Idle.

 

Setz mal dein BIOS zurück, normalerweise brauchst du explizit nix einstellen für das Idle, standardmäßig sind die normalerweise schon gut eingestellt.

 

Muss aber auch sagen ich verwende den powersave governor.

Link to comment
4 minutes ago, ich777 said:

Puh, das ist schon viel zu viel.

 

Das noch immer...

 

Mein System in dieser config hat gerade mal 70 bis 75W verbraucht im Idle mit 1x HDD, 2x SSD & 2x NVME aktiv:

 

Ich hab jetzt aber fast keine Addon Karten mehr drin dafür 1 SSD mehr und bin jetzt auf ca. 50 - 55W im Idle.

 

Setz mal dein BIOS zurück, normalerweise brauchst du explizit nix einstellen für das Idle, standardmäßig sind die normalerweise schon gut eingestellt.

 

Muss aber auch sagen ich verwende den powersave governor.

Das denk ich mir danke für deine Antwort!
 

BIOS upadate wurde von mir gemacht und da ist fast alles auf high power hab das alles abgeschaltet.

 

 

Ich denke das mein Problem die Cstates sind aber bekomme dies nicht hin!

 

geht deine CPU in c10?

Link to comment
3 hours ago, Patzi said:

Hardware :

Mainboard: Asus Proart z790

CPU Intel 13900k

Ram: 128Gb Kingston Fury

Netzteil: Bequit 650Watt Platinium

 

Und das ist alles? keine separate GPU, welche NVMEs? Sonstige Steckkarten?

Was sagt Powertop bei "Tunables"?

Link to comment
21 minutes ago, Patzi said:

BIOS upadate wurde von mir gemacht und da ist fast alles auf high power hab das alles abgeschaltet.

Lass mal alles so wie es ist bitte.

 

21 minutes ago, Patzi said:

geht deine CPU in c10?

Nein, C7.

Soweit ich weiß ist es unwahrscheinlich das deine CPU in C10 geht sobald du auch nur eine PCIe Erweiterungskarte im System hast.

 

Es wäre auch mal sehr hilfreich wenn du deine Diagnostics postest da dann die Leute die wirklich was vom Stromsparen verstehen deine Systemgeräte sehen.

 

Ich kann mir aber kaum vorstellen das es an den C-States liegt das du so viel höheren Stromverbrauch hast.

Link to comment

Nein

29 minutes ago, jj1987 said:

 

Und das ist alles? keine separate GPU, welche NVMEs? Sonstige Steckkarten?

Was sagt Powertop bei "Tunables"?

Nein keine weitere GPU , habe eine Hauppauge WinTV-quadHD eingebaut hab sie für Testzwecke auch ausgebaut und hab keine Änderung vom Stromverbrauch feststellen können!

 

NVME :

Fanxiang_S770_2TB 2Stk als pool

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.