[Support] Linuxserver.io - Ombi


570 posts in this topic Last Reply

Recommended Posts

  • Replies 569
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

That 'asshole' would be me.        Please keep in mind that I have a full time demanding job, a child, a 10 month old and a wife outside of what I do in ombi. All of my free time i

Ran into this too and it looks like this is the issue. Look at my post there (currently the last one) for a fix you can do without having to install anything into your container. It looks like they ad

Application Name: Ombi Application Site: https://ombi.io Docker Hub: https://hub.docker.com/r/linuxserver/ombi/ Github: https://github.com/linuxserver/docker-ombi   Please

Posted Images

  • 1 month later...

Has anyone ran into the problems where you request a movie/tv show on the mobile app, but you receive an error stating:

 

"cannot deserialize the current json array (e.g. [1,2,3]) into type Ombi Mobile.Models.Ombi.V1.RequestResult..."

 

Looking to get this working on the mobile app. It works fine in the browser.

Link to post

Ombi has been running fine for me since mid march.

I made a change to my library structure last week and since then, nothing has updated in ombi.
I re-added all my libraries in the plex settings, but every time it scans it errors out in the log with hundreds of these entries.
I had switched the plex agents to the legacy trying to fix this, but alas it did not work.
Any Suggestions?
Edit: After going through the logs, it looks like its only hung up on one out of 6 libraries.. which makes it even odder. (still 250+ errors)

2020-09-29 07:30:00.399 -04:00 [Error] Exception when adding new Movie "Ice Age: Collision Course"
Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: [. Path 'MediaContainer.Metadata[0].Guid', line 1, position 3545.
   at Newtonsoft.Json.JsonTextReader.ReadStringValue(ReadType readType)
   at Newtonsoft.Json.JsonTextReader.ReadAsString()
   at Newtonsoft.Json.JsonReader.ReadForType(JsonContract contract, Boolean hasConverter)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.PopulateObject(Object newObject, JsonReader reader, JsonObjectContract contract, JsonProperty member, String id)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateObject(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, JsonContainerContract containerContract, JsonProperty containerMember, Object existingValue)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.PopulateList(IList list, JsonReader reader, JsonArrayContract contract, JsonProperty containerProperty, String id)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateList(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, Object existingValue, String id)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.SetPropertyValue(JsonProperty property, JsonConverter propertyConverter, JsonContainerContract containerContract, JsonProperty containerProperty, JsonReader reader, Object target)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.PopulateObject(Object newObject, JsonReader reader, JsonObjectContract contract, JsonProperty member, String id)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateObject(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, JsonContainerContract containerContract, JsonProperty containerMember, Object existingValue)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.SetPropertyValue(JsonProperty property, JsonConverter propertyConverter, JsonContainerContract containerContract, JsonProperty containerProperty, JsonReader reader, Object target)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.PopulateObject(Object newObject, JsonReader reader, JsonObjectContract contract, JsonProperty member, String id)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateObject(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, JsonContainerContract containerContract, JsonProperty containerMember, Object existingValue)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.Deserialize(JsonReader reader, Type objectType, Boolean checkAdditionalContent)
   at Newtonsoft.Json.JsonSerializer.DeserializeInternal(JsonReader reader, Type objectType)
   at Newtonsoft.Json.JsonConvert.DeserializeObject(String value, Type type, JsonSerializerSettings settings)
   at Newtonsoft.Json.JsonConvert.DeserializeObject[T](String value, JsonSerializerSettings settings)
   at Ombi.Api.Api.Request[T](Request request) in C:\projects\requestplex\src\Ombi.Api\Api.cs:line 78
   at Ombi.Api.Plex.PlexApi.GetMetadata(String authToken, String plexFullHost, Int32 itemId) in C:\projects\requestplex\src\Ombi.Api.Plex\PlexApi.cs:line 159
   at Ombi.Schedule.Jobs.Plex.PlexContentSync.ProcessServer(PlexServers servers, Boolean recentlyAddedSearch) in C:\projects\requestplex\src\Ombi.Schedule\Jobs\Plex\PlexContentSync.cs:line 264

 

Edited by Geekd4d
Link to post

Have an issue where all the plex user accounts have been deleted.  The only user accounts that remain are manual ones that were created in Ombi.  Has this happened to anyone else?  Any fix to retrieve or should I just start from scratch and create new accounts in Ombi.

Link to post

Have an issue where the container won’t start when connected to my reverse proxy. On the local network it starts no problem but when I connect to my custom proxy network the container won’t start and gives me an exception error Code 403. 
 

any ideas?

Link to post
  • 4 weeks later...
On 8/21/2020 at 1:56 PM, aptalca said:

There is already an image tag called "v4-preview" for testing and dev purposes.

When tidusjar (ombi dev) pushes v4 to master/stable, our image will update the latest tag accordingly.

Humm... but the latest patch says to move to v4 and they've changed the projects default branch. I hope they merge down to master/main.

Quote

 

Just a small fix around a potential security issue.

This is the last main fix for the V3 build, please going forward move to V4

 

 

Link to post
On 11/3/2020 at 3:04 PM, tidusjar said:

V3 is still usable. I'll be merging down once I have finished a few things off 

Great, thanks! Can you let us know in this thread when this happens. I am using the preview tag and would be good once I can drop it from the docker config.

Link to post
On 9/29/2020 at 6:53 AM, Geekd4d said:

Ombi has been running fine for me since mid march.

I made a change to my library structure last week and since then, nothing has updated in ombi.
I re-added all my libraries in the plex settings, but every time it scans it errors out in the log with hundreds of these entries.
I had switched the plex agents to the legacy trying to fix this, but alas it did not work.
Any Suggestions?
Edit: After going through the logs, it looks like its only hung up on one out of 6 libraries.. which makes it even odder. (still 250+ errors)


2020-09-29 07:30:00.399 -04:00 [Error] Exception when adding new Movie "Ice Age: Collision Course"
Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: [. Path 'MediaContainer.Metadata[0].Guid', line 1, position 3545.
   at Newtonsoft.Json.JsonTextReader.ReadStringValue(ReadType readType)
   at Newtonsoft.Json.JsonTextReader.ReadAsString()
   at Newtonsoft.Json.JsonReader.ReadForType(JsonContract contract, Boolean hasConverter)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.PopulateObject(Object newObject, JsonReader reader, JsonObjectContract contract, JsonProperty member, String id)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateObject(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, JsonContainerContract containerContract, JsonProperty containerMember, Object existingValue)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.PopulateList(IList list, JsonReader reader, JsonArrayContract contract, JsonProperty containerProperty, String id)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateList(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, Object existingValue, String id)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.SetPropertyValue(JsonProperty property, JsonConverter propertyConverter, JsonContainerContract containerContract, JsonProperty containerProperty, JsonReader reader, Object target)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.PopulateObject(Object newObject, JsonReader reader, JsonObjectContract contract, JsonProperty member, String id)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateObject(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, JsonContainerContract containerContract, JsonProperty containerMember, Object existingValue)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.SetPropertyValue(JsonProperty property, JsonConverter propertyConverter, JsonContainerContract containerContract, JsonProperty containerProperty, JsonReader reader, Object target)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.PopulateObject(Object newObject, JsonReader reader, JsonObjectContract contract, JsonProperty member, String id)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateObject(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, JsonContainerContract containerContract, JsonProperty containerMember, Object existingValue)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.Deserialize(JsonReader reader, Type objectType, Boolean checkAdditionalContent)
   at Newtonsoft.Json.JsonSerializer.DeserializeInternal(JsonReader reader, Type objectType)
   at Newtonsoft.Json.JsonConvert.DeserializeObject(String value, Type type, JsonSerializerSettings settings)
   at Newtonsoft.Json.JsonConvert.DeserializeObject[T](String value, JsonSerializerSettings settings)
   at Ombi.Api.Api.Request[T](Request request) in C:\projects\requestplex\src\Ombi.Api\Api.cs:line 78
   at Ombi.Api.Plex.PlexApi.GetMetadata(String authToken, String plexFullHost, Int32 itemId) in C:\projects\requestplex\src\Ombi.Api.Plex\PlexApi.cs:line 159
   at Ombi.Schedule.Jobs.Plex.PlexContentSync.ProcessServer(PlexServers servers, Boolean recentlyAddedSearch) in C:\projects\requestplex\src\Ombi.Schedule\Jobs\Plex\PlexContentSync.cs:line 264

 

I have the same issue, posting screenshots here. Appears not to be all of my library or any of them in particular causing this. Is there a known resolution?

Ombi Plex Add.PNG

Ombi Import Fail.PNG

Ombi Success.PNG

Link to post
  • 2 weeks later...

Perhaps someone can help me with a weird issue I am having with Ombi.  I have it set up with a reverse proxy using LetsEncrypt (now Swag), and it works perfectly via the web or organizrr.  The issue I am having has to do with the Ombi iPhone app.  On a fresh start of the Ombi docker, the app works as advertised.  However, after some period of time (maybe a few hours), the app has an issue with requesting content (takes a while, then gives a “The request timed out” message.  The only way I can get it to work again is to restart the Ombi docker.  Of course, my workaround is to run a user script that restarts the Ombi docker periodically, but this is a band-aid until I can actually solve the issue.

 

Here is my Swag config:

 

# first go into ombi settings, under the menu "Ombi" set the base url to /ombi and restart the ombi container

location /ombi {
    return 301 $scheme://$host/ombi/;
}

location ^~ /ombi/ {
    # enable the next two lines for http auth
    #auth_basic "Restricted";
    #auth_basic_user_file /config/nginx/.htpasswd;

    # enable the next two lines for ldap auth, also customize and enable ldap.conf in the default conf
    #auth_request /auth;
    #error_page 401 =200 /login;

    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_ombi ombi;
    proxy_pass http://$upstream_ombi:3579;
}

# This allows access to the actual api
location ^~ /ombi/api {
    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_ombi ombi;
    proxy_pass http://$upstream_ombi:3579;
}
if ($http_referer ~* /ombi) {
    rewrite ^/api/(.*) /ombi/api/$1? redirect;
}

# This allows access to the documentation for the api
location ^~ /ombi/swagger {
    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_ombi ombi;
    proxy_pass http://$upstream_ombi:3579;
}
if ($http_referer ~* /ombi) {
    rewrite ^/swagger/(.*) /ombi/swagger/$1? redirect;
}

 

Appreciate any help/insight!  Having to restart the docker really defeats the purpose of having the iPhone app for convenience...and hopefully this can help solve the problem for anyone else with this experience.

 

Link to post

Hi Guys,

 

Hoping someone can help. I'm running Ombi on Docker (Synology NAS). I was able to install and run v3 without a problem but when I wanted to try the v4 (v4-preview) I get the following error at the bottom of the logs:


We are running on http://*:3579,,
i,
System.IO.FileNotFoundException: Could not find file '/opt/ombi/Swagger.xml'.,
File name: '/opt/ombi/Swagger.xml',
 

I have tried deleting and starting from scratch but no joy. 

 

Any ideas for me to try?

Link to post
25 minutes ago, Alias_ZA said:

Ombi on Docker (Synology NAS)

26 minutes ago, Alias_ZA said:

Any ideas for me to try?

On 1/3/2017 at 9:30 AM, linuxserver.io said:

If you are not using Unraid (and you should be!) then please do not post here, instead head to linuxserver.io to see how to get support.

 

Link to post
  • 2 weeks later...
  • 4 weeks later...

Anyone else having issues with TV search not working / loading recently (like... sometime in the past week or so)?

 

Mine has seemingly broke. Movie search loads fine and you can search, but the TV tab seemingly times out just loading. Searching returns no results. Getting the following error pretty much constantly.

 

at Microsoft.AspNetCore.Mvc.Internal.ControllerActionInvoker.InvokeActionMethodAsync()
at Microsoft.AspNetCore.Mvc.Internal.ControllerActionInvoker.InvokeNextActionFilterAsync()
at Microsoft.AspNetCore.Mvc.Internal.ControllerActionInvoker.Rethrow(ActionExecutedContext context)
at Microsoft.AspNetCore.Mvc.Internal.ControllerActionInvoker.Next(State& next, Scope& scope, Object& state, Boolean& isCompleted)
at Microsoft.AspNetCore.Mvc.Internal.ControllerActionInvoker.InvokeInnerFilterAsync()
at Microsoft.AspNetCore.Mvc.Internal.ResourceInvoker.InvokeNextResourceFilter()
at Microsoft.AspNetCore.Mvc.Internal.ResourceInvoker.Rethrow(ResourceExecutedContext context)
at Microsoft.AspNetCore.Mvc.Internal.ResourceInvoker.Next(State& next, Scope& scope, Object& state, Boolean& isCompleted)
at Microsoft.AspNetCore.Mvc.Internal.ResourceInvoker.InvokeFilterPipelineAsync()
at Microsoft.AspNetCore.Mvc.Internal.ResourceInvoker.InvokeAsync()
at Microsoft.AspNetCore.Builder.RouterMiddleware.Invoke(HttpContext httpContext)
at Microsoft.AspNetCore.StaticFiles.StaticFileMiddleware.Invoke(HttpContext context)
at Swashbuckle.AspNetCore.SwaggerUI.SwaggerUIIndexMiddleware.Invoke(HttpContext httpContext)
at Swashbuckle.AspNetCore.Swagger.SwaggerMiddleware.Invoke(HttpContext httpContext)
at Ombi.ApiKeyMiddlewear.Invoke(HttpContext context) in C:\projects\requestplex\src\Ombi\Middleware\ApiKeyMiddlewear.cs:line 51
at Ombi.ErrorHandlingMiddleware.Invoke(HttpContext context) in C:\projects\requestplex\src\Ombi\Middleware\ErrorHandlingMiddlewear.cs:line 24
[41m[30mfail[39m[22m[49m: Ombi.ErrorHandlingMiddleware[0]
Something bad happened, ErrorMiddleware caught this
System.Net.Http.HttpRequestException: Connection timed out ---> System.Net.Sockets.SocketException: Connection timed out
at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken)
--- End of inner exception stack trace ---
at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken)
at System.Threading.Tasks.ValueTask`1.get_Result()
at System.Net.Http.HttpConnectionPool.CreateConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken)
at System.Threading.Tasks.ValueTask`1.get_Result()
at System.Net.Http.HttpConnectionPool.WaitForCreatedConnectionAsync(ValueTask`1 creationTask)
at System.Threading.Tasks.ValueTask`1.get_Result()
at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
at System.Net.Http.RedirectHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
at System.Net.Http.HttpClient.FinishSendAsyncBuffered(Task`1 sendTask, HttpRequestMessage request, CancellationTokenSource cts, Boolean disposeCts)
at Ombi.Api.OmbiHttpClient.SendAsync(HttpRequestMessage request) in C:\projects\requestplex\src\Ombi.Api\OmbiHttpClient.cs:line 61
at Ombi.Api.Api.Request[T](Request request) in C:\projects\requestplex\src\Ombi.Api\Api.cs:line 38
at Ombi.Api.FanartTv.FanartTvApi.GetTvImages(Int32 tvdbId, String token) in C:\projects\requestplex\src\Ombi.Api.FanartTv\FanartTvApi.cs:line 27
at Ombi.Controllers.ImagesController.GetTvBanner(Int32 tvdbid) in C:\projects\requestplex\src\Ombi\Controllers\ImagesController.cs:line 45
at lambda_method(Closure , Object )
at Microsoft.AspNetCore.Mvc.Internal.ActionMethodExecutor.AwaitableObjectResultExecutor.Execute(IActionResultTypeMapper mapper, ObjectMethodExecutor executor, Object controller, Object[] arguments)

 

Looks like it is related to images? Not too sure, really haven't had to debug Ombi at all this past year.

 

EDIT: Wanted to update this and say that Ombi has begun working again as of a week or so ago. No changes made by me, so I am unsure what happened.

Edited by Heinami
Link to post
  • 2 weeks later...
On 8/21/2020 at 1:56 PM, aptalca said:

There is already an image tag called "v4-preview" for testing and dev purposes.

When tidusjar (ombi dev) pushes v4 to master/stable, our image will update the latest tag accordingly.

I would like to report you can migrate from Ombi v3 to Ombi v4

Current setup before upgrade:
Ombi - version 3.0.5227
Branch - develop <linuxserver/ombi:development>

I would recommend to stop your containers and make a backup before doing so.

Stop databse
download / copy (to a safe location)
Start database
Update Ombi
** of course if you're running rev-proxy as well as ombi, you can make backups of those too**


If you have any concerns with the update and need to revert you can perform the following:

Stop Ombi
top MariaDB
Delete MariaDB directory
Copy backup of MariaDB to appdata location
Start MariaDB
Update Ombi containers repo to ->  linuxserver/ombi:development-version-3.0.5227
Start Ombi


Best of luck everyone!

 

Edited by bombz
Link to post
  • 4 weeks later...
54 minutes ago, 007craft said:

How do I update this to be version 4?  I'm only getting Version 3 and I need the Jellyfin integration that been added to v4

You need to use the :v4-preview tag as v4 is not released as stable yet.

Link to post
  • 3 weeks later...
On 2/5/2021 at 2:32 PM, strike said:

You need to use the :v4-preview tag as v4 is not released as stable yet.


I added the :v4-preview tag and then checked the logs where it said this tag was now deprecated and to use the :development tag. I made the switch and still get stuck on the loading screen. This was after a fresh install as well. I guess I'll re-setup v3 and just wait for the official update.

Link to post
  • 1 month later...

In the process of setting up Ombi.  I can't get Ombi to see my plex server.  The Token and Identifier have auto filled out.  When I load servers in Plex Configuration it finds my server in the list.  Oddly it loads the port as 10101.  I change it to 32400 and it does no communicate with or without SSL.  Port 10101 doesn't work either.  My Plex is setup as Host and the Ombi is setup as Bridge.  At a bit of a loss.  Any help would be greatly appreciated.

 

UPDATE:  Not sure when this stopped working but I noticed the webgui for my plex docker doesn't seem to work anymore.  I get http://192.168.1.9:32400/web and "The connection was reset" popup.  Not sure if this is somehow related.  If I type https://192.168.1.9:32400/web it works but I get an SSL security warning.

 

SOLVED: i ticked the "Ignore any certificate errors" and restart the docker.  Is this normal?

Edited by Gragorg
Link to post

Does anyone have any luck with the IOS app?  If i load Ombi from the safari on my Iphone it works perfect.  The app seems to be only partially update.  Missing half the media availability.

Link to post
  • 3 weeks later...
On 3/27/2021 at 12:08 AM, Gragorg said:

Does anyone have any luck with the IOS app?  If i load Ombi from the safari on my Iphone it works perfect.  The app seems to be only partially update.  Missing half the media availability.

 

it seems the whole site is just tanking hard. I have tons of errors, just like the ones posted above, where scanning the library is producing tons of .NET errors. The integration into Sonarr and Radarr seem to work fine, the "availability" aspect is just a waste of time. iOS app seems to request fine, but again "availability" is shit.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.