Unraid OS version 6.12.4 available

Recommended Posts

Update: Updated 3 of 3 servers  / 2 of the 3 were perfect but 1 had small issue.


UPDATED: So the 6.12.2 server had some minor issues with the upgrade.  I had 2 network connections (I was using 2.5usb) and 1g on motherboard.  After the upgrade, it went back the 1g.  I needed to move ethernet cable, reboot, load the realtek RTL8156 Drivers again (but before upgrading, checked that there was no newer version).  Then reboot and move the ethernet in network settings and I was ok.   

The smallest of things can cause issues.



I have 3 servers that I will update tonight or tomorrow.  After reading some comments in this thread, I am slightly nervous with the people that said they lost there docker containers.   Using 6.12.3 on 2 servers and 6.12.2 on the other one.  Never had any problems with upgrading other than it would choose the wrong network adapter which was easily remedied.   With the previous updates, I followed all the steps, but never saw a comment "Lost all my dockers" that I see in this thread so wish me luck.  And if there are problems, hopefully someone here can point me in right direction.  I will report back once done, unless someone does not think I should do the upgrade yet.

Edited by GeorgeJetson20
updated notes
Link to comment
3 hours ago, ConnerVT said:


Not 6.12.x specific, but I have had similar experiences with my server when rebooting, so now I try to power down instead when it is necessary.  Likely not happening for the same reason for both of us, but thought I'd throw it out there as another data point.

Strange and interesting.  Thanks for the data point.  In my case, this never happened until 6.12.x though.

Link to comment

Issues with custom IPVLANL3 Docker network after the upgrade.

All my dockers run on a custom IPVLANL3 network after the up grade none of the dockers will

start and produce this error in the log “failed to create the ipvlan port: device or resource busy”


The custom network is present and all dockers are assigned to it.

If I roll back everything works correctly as it always has


root@NAS1:~# docker network ls
c672eff05a16   bridge      bridge    local
3bbd8bb2ae5c   host        host      local
de7e521a4485   ipvlan-l3   ipvlan    local
f6fe78a2336c   none        null      local


Link to comment

I reverted my custom ipvlan network back to macvlan and adjusted each container appropriately...I wish the UI would *always* remember the IP address that I end up typing in over and over when I change the network types...


I'll be watching this to see what the conflict is with ipvlan.  I have an idea what it is but I didn't dig too deep.



Link to comment



Upgraded from 6.12.3 and having issues with my dockers using custom ipv6 addresses. I'm getting this error:


docker: Error response from daemon: user specified IP address is supported only when connecting to networks with user configured subnets.



These are the settings which worked fine on 16.12.3:442749676_Screenshot2023-09-02111800.thumb.png.ca8dbeb478361301c565f73e07070cb0.png1492286895_Screenshot2023-09-02111626.thumb.png.883427403501b7bec92eee3a07127221.png



docker run
  -e TZ="Europe/London"
  -e HOST_OS="Unraid"
  -e HOST_HOSTNAME="tower"
  -e HOST_CONTAINERNAME="binhex-sabnzbd"
  -e 'TCP_PORT_8080'='8080'
  -e 'TCP_PORT_8090'='9090'
  -e 'UMASK'='000'
  -e 'PUID'='99'
  -e 'PGID'='100'
  -l net.unraid.docker.managed=dockerman
  -l net.unraid.docker.webui='http://[IP]:[PORT:8080]/'
  -l net.unraid.docker.icon='https://raw.githubusercontent.com/binhex/docker-templates/master/binhex/images/sabnzbd-icon.png'
  -v '/mnt/disks/WDC_1TB_BLACK/Sab':'/land':'rw,slave'
  -v '/mnt/cache/appdata/sab/':'/config':'rw' 'binhex/arch-sabnzbd:latest'

docker: Error response from daemon: user specified IP address is supported only when connecting to networks with user configured subnets.



Am I missing something? Going to have to roll back for now. If i remove the specified IPv6 Address it works fine.





Edited by dan91
Link to comment

Upgraded without major issue. Not a big deal as I don’t use bonds or bridges anymore and all my dockers are on my secondary network interface and unraid on primary. I moved as things were unstable and now they are I CBF reverting back. Don’t really notice the speed loss due bond. 

My only gripe is that the upgrade caused a Parity Check. Shutdown wasn’t unclean as I was observing it. Shame, as my scheduled monthly only finished yesterday. 

Edited by danioj
Link to comment
1 hour ago, itimpi said:

You can only be sure that it was not unclean if you successfully stopped the array before shutdown.

I know what you’re saying but honestly the reset happened in a matter of seconds ie the timeouts for unmounting / shutting down services that drive an unclean shutdown were not exceeded. I’m not aware of a scenario where services shutdown and drives are unmounted so quickly that still causes a unraid to think a parity check is still required on reboot? Happy to be educated though. 

Link to comment

When the array has been successfully stopped then Unraid normally writes this to the flash drive.   Either the stop or the write must have failed.


Having the syslog server enabled with mirror to flash options set to get a syslog that survives a reboot should allow confirmation of what went wrong if it happens again.

Link to comment

Hey guys, i just updated to 6.12.4 and was previously using ipvlan after some call traces with macvlan. I also have a bunch of dockers with custom: br0 network, so bridging was enabled. 

I updated now and disabled brdiging as per the release notes and started docker, but now my dockers wont start anymore. I have also read, that this can happen and i simply have to change to "custom: eth0", but that network does not exist. So i am unable to start my dockers now. What am i supposed to do? I want to switch back from ipvlan, because i had some issues with it, which is also documented in the release notes

Link to comment

I will add the GUI/scripts do not present the bond0/eth0 custom option it seems under some circumstances...for me, it was due to the presence of my custom ipvlan network.  That is expected behavior, but upon deleteion of the custom network, they should show with all the network/docker settings set appropriately.  They however do not.  I'm investigating...

Link to comment

Just updated from 6.11.3 to 6.12.4 and so far so good!

Previously plagued by crashing problems on 6.11.3, that always happened minutes after the appdata backup service would run successfully. When I heard news that it was related to macvlan, I changed over to ipvlan and it solved my crashing problem with an uptime of over 7 months after that. Now looking forward to learning ZFS.


Keep up the good work unraid team!

Link to comment

Ok guys, something aint right. I re-enabled bridging, but no luck. br0 is gone aswell now. Then i rolled back to 6.12.3 and i cant get br0 now there aswell

Something bricked now, i have no idea what is going on


Edit: It was ipv6 all along. I have no idea what happened, but the update borked my docker ipv6 settings and made unraid/docker unable to create any custom network interface


Edited by Joly0
Link to comment

upgraded from 6.12.3

- reboot triggered a parity check (unclean shutdown detected)

- custom docker network interface changed from bro to br2. I stopped docker to revert to br0 as eth0 is a 10GB interface.

My server was not subject to call traces with macvlan.

For now it runs smooth.

Link to comment

Upgraded my two servers from 6.12.3 to 6.12.4 and so far so good.


I wasn't getting any call traces or crashes with macvlan on a custom network through br0 but I still went ahead and disabled bridge on all interfaces. I hope the macvtap will be faster than the old bridged network.  

Link to comment

After upgrade from 6.11.5 to 6.12.4 where can I see that everything is configured correct? I don't see IPVLAN, MACVLAN or MACVTAB anywhere within the settings:






CLI shows that - but shouldn't there be MACVTAB somewhere?


root@Tower:~# docker network ls
8adcdd141eb5   bond0     macvlan   local
d0d7de380f93   bridge    bridge    local
bf554ebaaab7   host      host      local
68626f6bf303   none      null      local


Thanks in advance.


Edited by hawihoney
Link to comment

Hi everyone!
Update from 6.11.5 to 6.12.4.
No problems so far. (15min up time only ^^)

All my dockers work, including those behind a VPN.

Just "Fix Common Problems" reporting "macvlan call traces found".
My system has 2 network onboard motherboard. (1G + 2.5G) Only 2.5G unsed.

What do you recommend?

Should I switch to ipvlan? Or stay with macvlan?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.